[Flame][Notifications]Tap the top left on notication bar,keyboard pops up but search bar does not show up.

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: zikui.yang, Assigned: mikehenrty)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 wontfix, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(6 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v2.1][Notifications]Insert headset first to bring the Volume warning.
Tap the top left on notication view, keyboard pops up but the search bar does not show up. 
Attchment:VIDEO0166_clip.mp4 and logcat.txt
Happen time:6::21

[2.Testing Steps]: 
1.Play music
2.Insert Headset first time
3.Volume warning pops up
4.Tap the top left on notication view

[3.Expected Result]: 
4.When Volume warning pops up,the notification bar should be hidden. And then you tap the top left on screen,the keyboard should not pop up.

[4.Actual Result]: 
4.keyboard pops up withoIut bringing up search bar.

[5.Reproduction build]: 
Gaia-Rev        97873dca486abf4162a3345e71b375806937bdec
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ec87f4f41d3d
Build-ID        20141215001202
Version         34.0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: Free test
(Reporter)

Comment 1

4 years ago
Posted video VIDEO0166_clip.mp4
(Reporter)

Comment 2

4 years ago
Posted file logcat.txt
blocking-b2g: --- → 2.2?
Whiteboard: [systemsfe]
Assignee: nobody → evanxd
Unassigned, working on Bug 1112401.
Assignee: evanxd → nobody
blocking-b2g: 2.2? → 2.2+
Component: Gaia::System → Gaia::System::Window Mgmt

Updated

4 years ago

Comment 4

4 years ago
Posted file logcat_1552.txt
This issue can be repro on lasted build of Flame 2.2, I have uploaded the logcat of Flame 2.2
Found time:15:52
See attachment:logcat_1552.txt

Flame 2.2 build:
Gaia-Rev        3554ea9504046646b4679e3a61317c49fc55ca87
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/67c42c076393
Build-ID        20141228010205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141228.045435
FW-Date         Sun Dec 28 04:54:46 EST 2014
Bootloader      L1TC00011880
Alive, seems like a hierarchy issue. Do you know who can work on this?
Flags: needinfo?(alive)
regression window wanted. Suspect this is a gecko bug - touch event should not be dispatched to the dom element below the visible element.
Flags: needinfo?(alive)
Flame 2.0 behavior: The ability to enable Rocketbar search while in an app is NOT implemented in 2.0. I wouldn't call this a regression because the feature is not there to trigger the bug. Removing window-wanted tag.

Tested on:
Device: Flame 2.0 (KK, shallow flash, 319MB mem)
BuildID: 20141230195658
Gaia: 3c9bb36d9ade1a0acd5e1d6cbb5057be7f5ad484
Gecko: 7c50b02f59f5
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Is it possible to test older versions of 2.1 where this feature was present?
Flags: needinfo?(pcheng)
Behavior on first KK based 2.1 Aurora build: Tapping on upper left of the notification, Rocketbar interface could be brought up properly and putting the notification overlay in the background, as opposed to on latest builds where only keyboard is visible, but this still is NOT the expected behavior as written in comment 0.

See screenshot.

Tested on:
Device: Flame 2.1
BuildID: 20140904062538
Gaia: a47ecb6368c015dd72148acde26413fd90ba3136
Gecko: ffb144a500a4
Version: 34.0a2 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(pcheng)
Thanks for the clarification Pi Wei. Sounds like there are two bugs here: 1.) statusbar shouldn't sppear on the volume warning overlay, 2.) Volume warning should not be on top of rocketbar interface.

Let's get a regression-window for 2, when the Rocketbar interface stopped appearing over top of the Volume Warning overlay when tapping the statusbar.
You're welcome. Just to clarify, for this bug and comment 9, status bar doesn't actually visually appear when the notification overlay appears; so user is tapping on an imaginary Rocketbar which magically still works on comment 9 (and broken on original bug).

Working on the window for (2) of comment 10 now.
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
Behavior of 'Last Working' - see comment 9.
Behavior of 'First Broken' - see comment 0.

2.1 Aurora Regression Window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140904112239
Gaia: 01bb4c77f4a3672b9f8d939c125f5724840590ce
Gecko: c1e0cea51571
Version: 34.0a2 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140904165740
Gaia: cb230050e2f9a97d498f819389ad9ac65584bd74
Gecko: ab1812b495fd
Version: 34.0a2 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia: cb230050e2f9a97d498f819389ad9ac65584bd74
Gecko: c1e0cea51571

First Broken Gecko & Last Working Gaia - comment 9 behavior displays
Gaia: 01bb4c77f4a3672b9f8d939c125f5724840590ce
Gecko: ab1812b495fd

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/01bb4c77f4a3672b9f8d939c125f5724840590ce...cb230050e2f9a97d498f819389ad9ac65584bd74

Possibly caused by the patch for Bug 1058675.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on Eli, appears issue was caused by patch for bug 1058675, can you take a look?
Flags: needinfo?(pbylenga) → needinfo?(eperelman)
Eli is working on performance stuff now. I'll find somebody else to work on this.
Flags: needinfo?(eperelman) → needinfo?(mhenretty)
Assignee: nobody → mhenretty
The problem that bug 1058675 uncovered was that system dialogs are displayed below the gesture panels in the z-index rules. This doesn't make much sense since system dialogs cover the app window and rocketbar, and so should also block interacting with rocketbar and edge gestures. Another consequence of this z-index problem is that a user can perform an edge gesture with the system dialog up, and switch apps in the background without realizing it. We should fix that here as well.

Etienne, you did the review for bug 1058675, so I'm asking for your feedback on this patch. If you think this approach is sound I will add some integration tests.
Flags: needinfo?(mhenretty)
Attachment #8549993 - Flags: feedback?(etienne)
Comment on attachment 8549993 [details] [review]
[Gaia PR] move system dialog above gesture panels

sounds about right :)
would definitely take it with integration tests!
Attachment #8549993 - Flags: feedback?(etienne) → feedback+
Comment on attachment 8549993 [details] [review]
[Gaia PR] move system dialog above gesture panels

I could't reproduce the edge gestures being accessible from under the system update dialog, so the integration test only needs to cover the expanding rocketbar case.
Attachment #8549993 - Flags: review?(etienne)
Comment on attachment 8549993 [details] [review]
[Gaia PR] move system dialog above gesture panels

yeah we disable the edge gestures now in this case.
Attachment #8549993 - Flags: review?(etienne) → review+
master: https://github.com/mozilla-b2g/gaia/commit/4da1b058e56ebdd412d46825d60ec43b1ef89c0e
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8549993 [details] [review]
[Gaia PR] move system dialog above gesture panels

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Bug 1058675

[User impact] if declined:
User can open search app when a dialog is displayed but not see any of the search results. Poor UX.

[Testing completed]:
Manually tested, and added integration test.

[Risk to taking this patch] (and alternatives if risky):
Css only change.

[String changes made]: none
Attachment #8549993 - Flags: approval-gaia-v2.2?
(In reply to Michael Henretty [:mhenretty] from comment #20)
> Comment on attachment 8549993 [details] [review]
> [Gaia PR] move system dialog above gesture panels
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #):
> Bug 1058675
> 
> [User impact] if declined:
> User can open search app when a dialog is displayed but not see any of the
> search results. Poor UX.
> 
> [Testing completed]:
> Manually tested, and added integration test.
\o/ thanks for the integration test!
> 
> [Risk to taking this patch] (and alternatives if risky):
> Css only change.
> 
> [String changes made]: none
Attachment #8549993 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Target Milestone: --- → 2.2 S4 (23jan)

Comment 23

4 years ago
Posted video verify_video.mp4
This issue has been verified pass on Flame 2.2/3.0, when you tap the top left on Volume warning page,there is nothing pops up.
STR:
1.Launch Music.
2.Insert Headset for the first time.
3.Amplify the sound and make the Volume warning pops up.
4.Tap the top left on notication view.
**There is nothing pops up.
See attachment:verify_video.mp4
Rate:0/5

Flame 2.2 build:
Gaia-Rev        6e494f1d2676d231abba7dcc2e2822d1170d2d02
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9c8b785973bf
Build-ID        20150129162506
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150129.202729
FW-Date         Thu Jan 29 20:27:40 EST 2015
Bootloader      L1TC000118D0

Flame 3.0 build:
Gaia-Rev        9d2378a9ef092ab1fc15c3a9f7fc4171aab59d57
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/6bfc0e1c4b29
Build-ID        20150129010239
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150129.043711
FW-Date         Thu Jan 29 04:37:21 EST 2015
Bootloader      L1TC000118D0

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage?], [MGSEI-Triage+]
Depends on: 1148003
You need to log in before you can comment on or make changes to this bug.