SHB: System update ready dialog is off on Lock Screen

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: gwagner, Assigned: apastor)

Tracking

({regression})

unspecified
2.2 S9 (3apr)
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

Reporter

Description

4 years ago
On current nightly with SHB enabled.
Reporter

Comment 1

4 years ago
Can we do a branch check?
Keywords: qawanted
Whiteboard: [systemsfe]
This issue reproduces on Flame 3.0 and 2.2.

Observed behavior: With SHB enabled and while on lockscreen, the screen overlay that informs user the update is ready for installing is not covering the whole screen. This issue only occurs on lockscreen and does NOT occur if the device is past lockscreen when receiving the dialog.

Device: Flame 3.0 Master (Full flash 319MB KK)
BuildID: 20150324010202
Gaia: efebbafd12fc42ddcd378948b683a51106517660
Gecko: 840cfd5bc971
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (Full flash 319MB KK)
BuildID: 20150326002504
Gaia: e59ac067a1d22b7a72cbebc892ec652723f2a557
Gecko: 04b4b9d1faae
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

------------

This issue does NOT reproduce on Flame 2.1, the dialog does NOT display while on lockscreen. It would only display the dialog after I unlock the screen. If it is NOT supposed to display the dialog over lockscreen then this is a regression. If it is then 2.1 behavior is not valid. I'm adding regression keyword for now.

Device: Flame 2.1
BuildID: 20150326001202
Gaia: 6f39e4e876152de1dcdcc0e7656197f22f105e4b
Gecko: e00ae73d67a2
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawantedregression
This should not appear on the lockscreen so this is a regression.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
QA Contact: ychung
Assignee

Updated

4 years ago
Assignee: nobody → apastor
Assignee

Comment 5

4 years ago
Comment on attachment 8585478 [details] [review]
[gaia] albertopq:1148003-system-update > mozilla-b2g:master

Regression of bug 1112534. Can you r?, Michael?
Attachment #8585478 - Flags: review?(mhenretty)
Reporter

Comment 6

4 years ago
SHB issue
blocking-b2g: 2.2? → 2.2+
Reporter

Updated

4 years ago
Blocks: 1112534
Comment on attachment 8585478 [details] [review]
[gaia] albertopq:1148003-system-update > mozilla-b2g:master

Thanks for the fix!
Attachment #8585478 - Flags: review?(mhenretty) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Assignee

Comment 9

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/13f21bfd31e36a5eab37e00f0d7d74b8c2b079f9
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 10

4 years ago
Comment on attachment 8585478 [details] [review]
[gaia] albertopq:1148003-system-update > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1112534
[User impact] if declined: All the system dialogs can be shown in top of the lockscreen
[Testing completed]: Manual tests. CSS only. However, the bug that caused the regression has a UI test that is still passing, so both issues are fixed.
[Risk to taking this patch] (and alternatives if risky): One css liner. The new z-index is the same it was before the regression. Low risk.
[String changes made]: none
Attachment #8585478 - Flags: approval-gaia-v2.2?
Attachment #8585478 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Pi Wei, could you help verify this?
Flags: needinfo?(pcheng)
This issue is verified fixed on Flame 3.0 and 2.2. The system update ready dialog does NOT appear over lockscreen when software home button is enabled.

Device: Flame 2.2 (full flashed 319MB nightly production KK)
BuildID: 20150414002504
Gaia: 73645b097720f3ca594a14d288b87d3885d7fc9d
Gecko: 85ea1be9ac7d
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0 Master (full flashed 319MB nightly production KK)
BuildID: 20150413010203
Gaia: 3c68964cb9fdba7cf0f6829b7f44562acaf1f1d7
Gecko: 0a46652bd992
Version: 40.0a1 (3.0 Master)
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pcheng) → needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.