for-in should only use the new iteration protocol

RESOLVED DUPLICATE of bug 1246318

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1246318
4 years ago
2 years ago

People

(Reporter: evilpie, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
In bug 783829, to move forward we changed the js::IteratorMore code so that it allows both the old protocol (with StopIterator) and the new protocol with {value,done}. When we eventually remove __iterator__ and either remove Iterator and legacy generators or move them to the new protocol. Then we should be able to just use the new protocol.
(Reporter)

Updated

4 years ago
Summary: for-in should only use the new iteration protocol only → for-in should only use the new iteration protocol
(Reporter)

Updated

3 years ago
Depends on: 1098412
(Reporter)

Comment 1

2 years ago
I am going to remove the new iteration protocol from IteratorMore, because it is not really required anymore.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1246318
You need to log in before you can comment on or make changes to this bug.