Closed Bug 1112607 Opened 5 years ago Closed 5 years ago

about:* print preview stalls

Categories

(Toolkit :: Printing, defect)

37 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1119563
Tracking Status
e10s ? ---

People

(Reporter: pf, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20141216030203

Steps to reproduce:

While doing ancillary testing for bug 1112380, discovered that about:* pages don't crash. So, tried printing about:config (filtered with "e10s").


Actual results:

Opens a New Tab, and displays this dialog:
  Print Preview
  Title: about:config
  Progress: Preparing...

which stays on screen -- never finishes, so must be closed.


Expected results:

Move on to Print dialog..?
Summary: about print preview stalls → about:* print preview stalls
Component: Untriaged → Printing
Product: Firefox → Toolkit
This just does nothing on 35, but it breaks as described on nightly. In particular:

NS_ERROR_UNEXPECTED: component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIWebBrowserPrint.printPreview] (browser-content.js:429):

docShell.printPreview.printPreview(printSettings, contentWindow, this);


which should probably check that it's a XUL doc and then warn ("Can't print a XUL document") and do nothing, which is what trying to print it on OS X does (at least used to do, before e10s).

Mike, is this your kind of thing? :-)
tracking-e10s: --- → ?
Flags: needinfo?(mconley)
Keywords: regression
OS: Linux → All
Hardware: x86_64 → All
Yeah, this isn't great, but will probably be mitigated by bug 1119563 and bug 1119562.
Flags: needinfo?(mconley)
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1119563
You need to log in before you can comment on or make changes to this bug.