Closed Bug 1113083 Opened 5 years ago Closed 3 years ago

SVG/SMIL: using svg as background-image pauses animation on pageload.

Categories

(Core :: ImageLib, defect)

26 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 935888

People

(Reporter: pepijnfens, Assigned: jwatt)

References

Details

(Keywords: regression, testcase)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

Create a file with a <div> with an svg file (animated in smil) as a background-image.

To create a bottomline, I used sam herberts SVG loaders and changed the html file to include the loaders as background-image.
http://samherbert.net/svg-loaders/



Actual results:

When opening the page in firefox this animation will appear to be paused.
After a refresh, the animation does start.

I assume this has to do with caching, only triggering the animation to start when it is already loaded?


Expected results:

The animation should start right away, or at least at the moment the .svg resource file is completely loaded. Now, it needs a refresh before it actually starts.
Could you attach a testcase, please.
Flags: needinfo?(pepijnfens)
Keywords: testcase-wanted
The svg file is taken from sam herberts excellent svg loaders, I've copied it to my dropbox to make sure it's available when you open the html locally.
Flags: needinfo?(pepijnfens)
Keywords: testcase-wanted
Component: Untriaged → ImageLib
Product: Firefox → Core
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think it's a dupe of bug 908634.
Keywords: regression, testcase
Not the same regression range in fact.

good=2013-09-04
bad=2013-09-05
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e3785e299ab6&tochange=77ed46bf4c1a

Suspected bug:
Jonathan Watt — Bug 907503 - Fix invalidation for SMIL animation in SVG-as-an-image. r=roc
Blocks: 907503
Version: 34 Branch → 26 Branch
Flags: needinfo?(jwatt)
Assignee: nobody → jwatt
Flags: needinfo?(jwatt)
( So caused by the first half of http://hg.mozilla.org/mozilla-central/rev/8d8c2ce395a1 )
Two things I'd note after looking at this a bit:

 * backing out bug 907503 doesn't fix this (maybe because of bug 908634?)
 * the animation only fails on initial load or hard reloads (soft reloads get it working)
In local build
Last Good: e1976a0ce384
First Bad: f12a3d9e4cd6

Triggered by:	f12a3d9e4cd6	Jonathan Watt — Bug 911862 - Make VectorImage use the refresh driver to send out frame change notifications. r=dholbert
Blocks: 911862
No longer blocks: 907503
Flags: needinfo?(jwatt)
Flags: needinfo?(jwatt)
pretty sure the landing of bug 935888 has fixed this.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Depends on: 935888
Yes, I verified, we can even dupe it.
No longer depends on: 935888
Resolution: FIXED → DUPLICATE
Duplicate of bug: 935888
You need to log in before you can comment on or make changes to this bug.