[Settings][Internet Sharing] Unable to open Hotspot Settings menu.

VERIFIED FIXED

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Marty, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-Daily-Testing])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Description:
The user is unable to open the WiFi Hotspot Settings menu in the Internet Sharing screen.  Tapping on Hotspot Settings will highlight the menu button, but not navigate to that settings screen.

Note: This is possibly related to bug 1113099
   
Repro Steps:
1) Update a Flame device to BuildID: 20141218040201
2) Open the Settings app and navigate to Internet Sharing
3) Tap on Hotspot Settings
  
Actual:
Hotspot Settings is highlighted, but the settings screen is not opened.

Expected: 
Tapping on Hotspot Settings opens the settings screen to change the Name, Password, and security settings for a WiFi hotspot.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141218040201
Gaia: 58734e8a48157f99d5b733412b600c2e04c954fe
Gecko: 5c7a6294b82a
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 4/4
See attached: logcat
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Functional regression of a core feature.

Calling for a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: pcheng

Comment 2

4 years ago
qawanted to see if the issue is still here after bug 1113099 is fixed, thanks
Keywords: qawanted
(In reply to howie [:howie] from comment #2)
> qawanted to see if the issue is still here after bug 1113099 is fixed, thanks

This issue is no longer reproducible on latest central tinderbox engineering build. Hotspot settings can be accessed and functions as expected.

Device: Flame 2.2 Master
BuildID: 20141218150004
Gaia: 2650bae535e15eef5f299cc80d4fab460f78ada7
Gecko: 1427b365cd39
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
marking as fixed by patch to bug 1113099 per comment 2 and comment 3
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: pcheng
Resolution: --- → FIXED

Comment 5

4 years ago
Verified the issue is fixed on Flame 2.2
As per comment 2 and 4, "Hotspot settings" can be accessed and functions as expected.

"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141219040202
Gaia: deb90229734e5397cda806fb11f2e001fba83399
Gecko: 021b09e92d30
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
+ for fixed regression.
Blocks: 1113099
blocking-b2g: 2.2? → 2.2+
You need to log in before you can comment on or make changes to this bug.