Closed Bug 1113298 Opened 5 years ago Closed 5 years ago

Recipient autocomplete: From results dropdown, select any but 1st entry via mouse click, then Ctrl+Enter to send message immediately: sudden change to another recipient (1st result)

Categories

(Thunderbird :: Message Compose Window, defect, critical)

33 Branch
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 37.0

People

(Reporter: guestroom3, Unassigned)

References

Details

(Whiteboard: [fixed by bug 1043310])

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

{write}{to field}{typing first letter of address to trigger auto complete}{choosing the address from auto complete list using mouse}{ctrl-enter to send immediately}


Actual results:

the address in recipiants  'to' field, changed immediately upon hitting ctrl-enter to another address in the auto complete list described above+normal "send without subject ?" message


Expected results:

send message normally after the "send without subject?" warning
Severity: normal → critical
Phenomenon was observed in Tb 31.3.0.
  0. "Confirmation dialog for Ctrl+Enter" is enabled.
  1. Select first To:
  2. Type "z" at second To: field -> candidates = zzz1, zzz2, zzz3, ... zzz1 is shown at To: field with highlited.
  3. Select zzz3 from selection list, without moving cursor, Ctrl+Enter
  4. Second To: field is changed to zzz1 immediately, then Confirmation Dialog is shown.
If Send button/menu, selected field is moved from To: field to other element, so "Enter mail address at To: field" is normally accepted. But if "mail address selection with autocomplete" ended but Ctrl+Enter is pressed without moving to other field, "Send by Ctrl+Enter" is invoked before selected mail address is saved in gMsgCompose.compFields.

At step 2(when candidates are shown), first candidate looks already set in gMsgCompose.compFields. And, when other mail address is selected, selected mail address doesn't look saved in gMsgCompose.compFields.
No onchange like event when selection completed?
Status: UNCONFIRMED → NEW
Ever confirmed: true
It was not Ctrl+Enter only problem.
  1. Type "z" at To: field -> candidates = zzz1, zzz2, zzz3, ... zzz1 is shown at To: field with highlighted.
  2. Select zzz3 from selection list
  3.without moving cursor, press Enter
      => zzz1(first candidate by autocomplete) is shown at To: field, and second To: field is shown.

If focus is move to other place(for example, click at Desktop) after step 2, and if focus is moved back to composer window by click of "composer in Task Bar ", problem is not observed at step 3.
IIRC, onchange event is kicked upon focus change etc. only....
Following action may be needed.
   When Enter is pressed, if input field is focused, move focus to other field such as button then move focus back to input field.
Basically dupe of bug 1107844 I think.
(In reply to Magnus Melin from comment #3)
> Basically dupe of bug 1107844 I think.

+1. But to be on the safe side, let's verify this special case after fixing that.
Depends on: 1107844
(In reply to WADA from comment #2)
>   2. Select zzz3 from selection list

WADA, this bug can only be reproduced when selecting zzz3 via *mouse-click*, right?
Summary: The newest version, ctrl-enter to send message immediately after choosing email recipiant from auto complete results in sudden change of the recipiant to another address → Recipient autocomplete: From results dropdown, select any but 1st entry via mouse click, then Ctrl+Enter to send message immediately: sudden change to another recipient (1st result)
OS: Windows XP → All
Hardware: x86 → All
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 1043310]
Target Milestone: --- → Thunderbird 37.0
You need to log in before you can comment on or make changes to this bug.