If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.
Bug 1113368 (Afrikaans-WordPrediction)

Add Afrikaans (af) autocorrection/wordsuggestion

RESOLVED DUPLICATE of bug 1113365

Status

Firefox OS
Gaia::Keyboard
RESOLVED DUPLICATE of bug 1113365
3 years ago
2 years ago

People

(Reporter: delphine, Unassigned)

Tracking

(Blocks: 1 bug, {branch-patch-needed})

unspecified
ARM
Gonk (Firefox OS)
branch-patch-needed
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+)

Details

Attachments

(1 attachment)

Afrikaans shipping from 2.0 onwards
[Blocking Requested - why for this release]:
Afrikaans is shipping on 2.0 and onwards
blocking-b2g: --- → 2.0?
Flags: needinfo?(bbajaj)
[Blocking Requested - why for this release]:

[Triage] Considering current 2.0 timing and the need from partner, nom. to 2.1 (or even 2.2?) instead for consideration.
blocking-b2g: 2.0? → 2.1?

Comment 3

3 years ago
Ok, I only saw this by accident now. I'm the owner for the Afrikaans locale.

With help, I can probably make a very minimal, simple wordlist for the earliest possible release that would be important. Can someone put me in contact with the right people to help with the technical details? Having working input is maybe even more important than UI localisation.

I'm not able to get up to speed on everything myself now. I assume someone can point me to the right repositories, branches, and requirement?
Need info Kevin who might be able to help out with technical aspects.
I will update this bug with the appropriate flag once we determine if this is needed on 2.0 and onwards, or on a later version(s). Thanks
Flags: needinfo?(bbajaj) → needinfo?(kscanne)

Comment 5

3 years ago
Friedel, I'm happy to help put together a frequency list from web data if you think it would be useful.
Flags: needinfo?(kscanne)

Comment 6

3 years ago
Thank you for the offer, Kevin. I think we should do that for a following version. For now I'll go very simple and just use the data I have at hand. In fact, I already started.

I do however need help on repositories, branches and the process, especially for getting into 2.0. I'll obviously target gaia master first, but we need to get at least a simple version in for 2.0  Delphine, can you connect me with the right person for that? I realise it is already down the line for 2.0.
For 2.0 process (and other branches), there is this: https://wiki.mozilla.org/Release_Management/B2G_Landing#v2.0

You would have to edit the appropriate .json file, create a pull request, link it here, ask for review. Then it would have to go through the usual approval process in order to land (we need this to get 2.0+'ed by Release Management). You would have to do that for all the branches you need (can be done in this same bug, just have 3 pull requests).

I haven't actually ever done this for autocorrection/wordsuggestion, so sorry I can't help more with that! Probably Kevin would be the right person to connect with for all this :)

Comment 8

3 years ago
Created attachment 8545216 [details] [review]
Pull request for basic Afrikaans input

This pull request implements a keyboard layout and basic dictionary for Afrikaans input on Gaia. I'm not sure what the dependencies are between these, so I put them together in one pull request.

I'd like to give it another day or so of testing before backporting to other branches, but I believe it is working reasonably well.
Attachment #8545216 - Flags: review?(timdream)
Comment on attachment 8545216 [details] [review]
Pull request for basic Afrikaans input

Hi Friedel!

Given you are the local export, I did not verify if the content of the patch, just the syntax of this code.

The first issue is that we changed the layout definition in bug 1047837 and introduced the |pages| array, so you should remove the 0th element (undefined) and put the |keys| and |alt| into it. The current patch would work but let's not use the workaround in new layouts.

Also, since bug 1047837 is not introduced in v2.1 or v2.0, you would need to create branch specific patches for these versions.

Thanks for the contribution!
Attachment #8545216 - Flags: review?(timdream) → feedback+
Keywords: branch-patch-needed
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #9)
> The first issue is that we changed the layout definition in bug 1047837 and
> introduced the |pages| array, so you should remove the 0th element
> (undefined) and put the |keys| and |alt| into it. The current patch would
> work but let's not use the workaround in new layouts.

See bug 1047837 comment 5.
You can also list your files in 

https://github.com/mozilla-b2g/gaia/blob/858c3d4b2fcb30ed4c76fd57b75d0a23f138be19/apps/keyboard/test/build/integration/keyboard_test.js

To ensure dict got included.
[Blocking Requested - why for this release]:

As per our call with Bus Dev, Rel Man and l10n team this morning, it is confirmed that this is needed on 2.0 (and onwards). Thus renominating for 2.0 work
blocking-b2g: 2.1? → 2.0?

Updated

3 years ago
blocking-b2g: 2.0? → 2.0+
Blocks: 1121352
Hi, 

Thanks for the effort! By the way, this is a critical issue for the launch. Do we have an ETA? 

Thanks again!
David
Let's land layout + dictionary in the same bug -- bug 1113365.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1113365
Alias: Afrikaans-WordPrediction
You need to log in before you can comment on or make changes to this bug.