[Homescreen] Rocketbar can be highlighted with carats without searching; carat under search icon

RESOLVED DUPLICATE of bug 1112473

Status

defect
RESOLVED DUPLICATE of bug 1112473
4 years ago
4 years ago

People

(Reporter: onelson, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-Daily-Testing])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description:
When at the homescreen, a user may hold tap on the 'Magnifying Glass/Search' icon in the top right and highlight the rocketbar with carats at both ends. Screenshot included.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141218040201
2) Hold tap on the 'Magnifying Glass/Search' icon.
3) Observe UI.
  
Actual:
Rocketbar has carats highlighting it, far left under the 'S' in "Search" and far right under the 'Magnifying Glass/Search' icon.
  
Expected: 
No carats are created when holding tap on the icon.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141218040201
Gaia: 58734e8a48157f99d5b733412b600c2e04c954fe
Gecko: 5c7a6294b82a
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
  
Repro frequency: 5/5
See attached: 
screenshot
logcat
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
(Reporter)

Comment 1

4 years ago
Attaching logcat mentioned above.
Tim, this looks like a text selection issue. Can you have someone take a look? Or do we need to specifically disable copy paste in the rocketbar.
blocking-b2g: --- → 2.2+
Flags: needinfo?(timdream)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1112473
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.