2 caret appears when long pressing the rocket bar

VERIFIED FIXED in 2.2 S2 (19dec)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: gchang, Assigned: kgrandon)

Tracking

unspecified
2.2 S2 (19dec)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
### Steps:
1. Go to home screen
2. Long press the rocket bar

### Expected:
1. There should be one caret

### Actual:
1. 2 carets appear and the positions of these 2 carets are different

### Reproduce rate
always

### Version:
Gaia-Rev        8ffb48c321bb9595ad437086c5eb450bc90aa714
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/8401afdb6e6c
Build-ID        20141216160204
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
(Reporter)

Comment 1

4 years ago
Posted image 2014-12-17.png
(Reporter)

Updated

4 years ago
QA Whiteboard: [textselection]
Duplicate of this bug: 1113390
Major glitch in front facing UI.
blocking-b2g: --- → 2.2+
Peter, does this require a platform fix or a system app fix?
Flags: needinfo?(pchang)
This should be fixed by bug 1098161.
Flags: needinfo?(pchang)
Depends on: 1098161
(In reply to peter chang[:pchang][:peter] from comment #5)
> This should be fixed by bug 1098161.

Oops...looks like this issue is still existed after bug 1098161. And gecko detects this element contains text. What are the difference between this rocketbar on homescreen and another rocketbar with keyboard? (after you click rocketbar, start to type something)
Flags: needinfo?(timdream)
(In reply to peter chang[:pchang][:peter] from comment #6)
> Oops...looks like this issue is still existed after bug 1098161. And gecko
> detects this element contains text. What are the difference between this
> rocketbar on homescreen and another rocketbar with keyboard? (after you
> click rocketbar, start to type something)

The actual rocket bar being typed is an <input type=search> in the System app. I don't know the hit area in Home screen app is and it is very likely it's just a button.

Anyway, you can use DevTools inspector to find out.
Flags: needinfo?(timdream)
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #7)
> (In reply to peter chang[:pchang][:peter] from comment #6)
> > Oops...looks like this issue is still existed after bug 1098161. And gecko
> > detects this element contains text. What are the difference between this
> > rocketbar on homescreen and another rocketbar with keyboard? (after you
> > click rocketbar, start to type something)
> 
> The actual rocket bar being typed is an <input type=search> in the System
> app. I don't know the hit area in Home screen app is and it is very likely
> it's just a button.
> 
> Anyway, you can use DevTools inspector to find out.

If so, we should add select:none for this area in home screen app. Does it already include in gaia homescreen app?
Flags: needinfo?(timdream)
Kevin, could you confirm?
Component: Gaia::System → Gaia::Homescreen
Flags: needinfo?(timdream) → needinfo?(kgrandon)
(Assignee)

Comment 11

4 years ago
Comment on attachment 8539049 [details] [review]
[PullReq] KevinGrandon:bug_1112473_home_screen_user_select to mozilla-b2g:master

This seems to work for me. I was unable to use select: none though, as it says that CSS selector is not supported on master. Other apps seem to use -moz-user-select, and using that here works.

Peter - I'm not sure who knows the select CSS stuff well, but since you gave a suggestion, would you be willing to put a review stamp on this? Thanks!
Flags: needinfo?(kgrandon)
Attachment #8539049 - Flags: review?(pchang)
(Assignee)

Updated

4 years ago
Assignee: nobody → kgrandon
Whiteboard: [systemsfe]
Comment on attachment 8539049 [details] [review]
[PullReq] KevinGrandon:bug_1112473_home_screen_user_select to mozilla-b2g:master

Looks good to me but I don't know who in gaia should review this patch. Chris, could you help to review?
Attachment #8539049 - Flags: review?(pchang)
Attachment #8539049 - Flags: review?(chrislord.net)
Attachment #8539049 - Flags: feedback+
(Reporter)

Updated

4 years ago
Attachment #8539049 - Flags: review?(chrislord.net) → review+
(Assignee)

Comment 13

4 years ago
In master: https://github.com/mozilla-b2g/gaia/commit/4cac716e425f877e3f31a5c1769cbcec40a0097f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

4 years ago
Verified @ 
Gaia-Rev        ab41c35eed35404b632a4841714b81b56364ba32
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2acb12da9813
Build-ID        20141224160204
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
Status: RESOLVED → VERIFIED
Target Milestone: --- → 2.2 S2 (19dec)
(Reporter)

Updated

4 years ago
QA Whiteboard: [textselection] → [COM=Text Selection]
You need to log in before you can comment on or make changes to this bug.