Closed Bug 1113633 Opened 5 years ago Closed 3 years ago

WebGL game "Barfight" no longer displays some textures (errors in shader.js)

Categories

(Web Compatibility :: Desktop, defect)

Firefox 38
defect
Not set

Tracking

(firefox34 unaffected, firefox35+ wontfix, firefox36+ wontfix, firefox37+ wontfix, relnote-firefox 35+)

RESOLVED WONTFIX
Tracking Status
firefox34 --- unaffected
firefox35 + wontfix
firefox36 + wontfix
firefox37 + wontfix
relnote-firefox --- 35+

People

(Reporter: FlorinMezei, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [contactready] [webgl])

Attachments

(2 files)

Attached image barfight_bad.png
Reproducible with: 
- Firefox 35 Beta 5 - BuildID: 20141218174327
- Firefox 36 Aurora latest - BuildID: 20141217004003
- Firefox 37 Nightly latest - BuildID: 20141218030202
NOT Reproducible with:
- Firefox 34.0.5

Reproducible on: Windows 7 x64, Windows 8.1 x86, Ubuntu 14.04 x86
Works on: Mac OS X 10.7.5

Steps to reproduce:
1. Open Firefox and go to http://www.tubagames.net/barfight/game.php.

Expected results:
The game loads, and then displays a bar with people.

Actual results:
The game loads but displays no people. The browser console displays errors like:
"Error: WebGL: linkProgram failed, with this log:
Types for uniform 'webgl_dcb03f6e55a92391' differ between vertex and fragment shaders
shader.js:139
Error: WebGL: getUniformLocation: program: deleted object passed as argument material.js:69"

See full console log at: http://pastebin.com/WpW3iWXg.

The issue reproduces the same way on IE and Chrome, but at the same time is a regression from 2014-10-10:
Regression window(m-c)
Good: 2014-10-09 (BuildID=20141009030201)
Bad: 2014-10-10 (BuildID=20141010030201)
Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5d6ec4dddf14&tochange=50b689feab5f

The main suspect seems to be https://bugzilla.mozilla.org/show_bug.cgi?id=1076020.
Attached image barfight_good.png
The issue was reproduced on AMD and NVidia cards.
See Also: → 1113637
Milan, can we get someone to look into this?
Flags: needinfo?(milan)
Looks like a game side error, we're just tougher on them?
Flags: needinfo?(milan) → needinfo?(jgilbert)
We might want to note this since, given the timing in the cycle, this will likely ship in 35.
Release noted as a known issue: "WebGL games might not display some textures"
(In reply to Lukas Blakk [:lsblakk] use ?needinfo from comment #6)
> Release noted as a known issue: "WebGL games might not display some textures"

It might be worth making that:

"Validation of shader precision specifiers is stricter which may cause some WebGL content that previously worked to stop working"
Jeff, Milan, are we going to work on that or do we expect them to fix their code?
Thanks
Flags: needinfo?(milan)
Flags: needinfo?(jmuizelaar)
(In reply to Sylvestre Ledru [:sylvestre] from comment #8)
> Jeff, Milan, are we going to work on that or do we expect them to fix their
> code?
> Thanks

This is a problem with there code (it doesn't work in Chrome either). They need to fix it.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jmuizelaar)
Resolution: --- → WONTFIX
So, should we TechEvangelism this?
Flags: needinfo?(milan)
Flags: needinfo?(jgilbert)
Component: Canvas: WebGL → Desktop
Product: Core → Tech Evangelism
Version: 35 Branch → Firefox 38
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Whiteboard: [contactready] [webgl]
Status: REOPENED → NEW
The game no longer loads in Firefox or Chrome, lots of mixed content warnings and other error messages.

I think we should close this as WONTFIX. Please reopen if you disagree.
Status: NEW → RESOLVED
Closed: 5 years ago3 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.