Search is performed with a suggestion text on the mouse pointer instead of inputted text if mouse moves over dropdown unintentionally

RESOLVED WORKSFORME

Status

()

P3
normal
Rank:
35
RESOLVED WORKSFORME
4 years ago
8 months ago

People

(Reporter: alice0775, Unassigned)

Tracking

({ux-error-prevention})

37 Branch
x86_64
Windows 7
ux-error-prevention
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox34 affected, firefox35 affected, firefox36 affected, firefox37 affected, firefox-esr31 unaffected)

Details

(Whiteboard: [fxsearch])

(Reporter)

Description

4 years ago
Steps To Reproduce:
1. Type text in SeacrhBar
   --- dropdown pops up automatically
2. Attempt to select search engine by keyboard( TAB, Down Arrow, Down Arrow...
   and move mouse pointer over the dropdown(assume that mouse has moved unintentionally)
   and continue Down Arrow, Down Arrow
3. Press ENTER to search with the selected search engine

Actual results:
Search is performed with a suggestion text on the mouse pointer instead of inputted text


Expected Results:
Search should be performed with the input text as intended.
During selection of search engine by keyboard, the browser should not replace the input text.
(In reply to Alice0775 White from comment #0)

Either I can't reproduce or don't think what I'm seeing is a bug.

> 2. Attempt to select search engine by keyboard( TAB, Down Arrow, Down
> Arrow...

This step isn't very specific about what I should press, so it's possible I'm not doing exactly the same thing as you did.
(Reporter)

Comment 2

4 years ago
(In reply to Florian Quèze [:florian] [:flo] from comment #1)
> (In reply to Alice0775 White from comment #0)
> 
> Either I can't reproduce or don't think what I'm seeing is a bug.
> 
> > 2. Attempt to select search engine by keyboard( TAB, Down Arrow, Down
> > Arrow...
> 
> This step isn't very specific about what I should press, so it's possible
> I'm not doing exactly the same thing as you did.

You should try with new searchbar ui on Firefox34.0.5 and later
(Reporter)

Comment 3

4 years ago
2. Attempt to select search engine by keyboard,
   i.e, 
   Press  TAB  DownArrow  DownArrow 
     mouse move over the dropdows daccidentally <--- (assume that mouse has moved unintentionally)
   DownArrow  DownArrow
That works for me. As soon as you move the mouse hover the suggestions, you are no longer selecting the search engine, but selecting a suggestion, and the last 2 down arrow keypresses just select another suggestion, which is the one that's searched (for me).
If I'm reading this correctly the suggestion is that the up/down arrows should only move within the suggestions if the highlight got there by mouse usage, not by mouse usage, is that correct?
Flags: needinfo?(alice0775)
(Reporter)

Comment 6

4 years ago
(In reply to Dave Townsend [:mossop] from comment #5)
> If I'm reading this correctly the suggestion is that the up/down arrows
> should only move within the suggestions if the highlight got there by mouse
> usage, not by mouse usage, is that correct?

No.
When a search engine is highlighted, up/down arrows should only move within Search engines even if mouse pointer  is on suggestions.
Flags: needinfo?(alice0775)
Losing your search term doesn't really warrant dataloss here, and this isn't really a regression since this feature didn't exist before.

Philipp, what are your thoughts on comment 6?
Flags: needinfo?(philipp)
Keywords: dataloss, regression
(Reporter)

Updated

4 years ago
Depends on: 1119987
Yeah, that's an odd behavior.
When navigating suggestions with the arrow keys, we actually replace the text in the search box (which makes sense). It is reasonable to assume that hitting enter will search for whatever is currently displayed in that box.
Flags: needinfo?(philipp)

Updated

4 years ago
Depends on: 1142334
Duplicate of this bug: 1139655
Duplicate of this bug: 1149743
See Also: → bug 1154300
Priority: -- → P3
Whiteboard: [fxsearch]

Updated

3 years ago
Rank: 35
It appears that this has been fixed, or at least it's fixed as of v58.

That is to say, when a search on the search bar (whether it's the one on about:home/about:newtab or the toolbar) is triggered with a press of the Enter key, the resulting search will be for the text shown in the search bar (whether it was typed in or picked from the suggestion list with arrow keys), never the drop-down suggestion the mouse is hovering over or the one it hovered over last.

Also, when triggering a search by clicking on the "Search" arrow button or clicking the icon of a one-off search provider, the search will be for the text shown in the search bar as well. It used to be that a one-off search would use whatever drop-down suggestion the mouse hovered over last, which was very irritating given how common it is to hover over a suggestion when moving the mouse to a one-off search button (see bug 1239361).

And when clicking on a drop-down suggestion, the clicked on suggestion is always what's searched for, no matter what text is in the search box.

If it's of any importance to this case, for the about:home/about:newtab searchbar, hovering the mouse over an item overrides the last selection that was made with the arrow keys. In other words, after mouse-hovering over a suggestion or one-off search provider, pressing the up/down arrow key will select the item above/below what the mouse is hovering over, NOT the item above/below whatever was previously highlighted by earlier up/down key presses. This does not affect one-off search selections made with the Tab key, however. Also, this does not happen in the toolbar searchbar, where mouse operations have no effect on up/down key operations.
This is also WFM since mouseover doesn't select anymore in the searchbar/addressbar.
I suspect we should do the same for in-content searches, but that should be in a separate bug.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.