Closed Bug 1149743 Opened 5 years ago Closed 5 years ago

Search bar uses search provider hovered by mouse on "enter"

Categories

(Firefox :: Search, defect)

37 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1113731

People

(Reporter: error401, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150324194038

Steps to reproduce:

- Enter some text in the search bar so it will cause suggestions to drop down when it's activated
- Hover mouse in area where search provider options (Search for "term" with:) will appear on activation of search bar
- De-focus search field (Esc or focus another input element)
- Activate search bar (Ctrl-K)
- Type search terms
- Press enter


Actual results:

- Search provider that happened to be hovered by the mouse is used


Expected results:

- Default search provider is used
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1113731
Component: Untriaged → Search
You need to log in before you can comment on or make changes to this bug.