If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

general.autoScroll does not work in 2.32

RESOLVED WONTFIX

Status

SeaMonkey
General
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Petr Voralek, Unassigned)

Tracking

({regression, relnote})

SeaMonkey 2.32 Branch
x86_64
Linux
regression, relnote

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix for 2.32; fixed in 2.33 by a combination of Bug 984037 and/or backing out Bug 938359 ([e10s] Support middle-click scroll))

User Story

Probably caused by Bug 938359 - [e10s] Support middle-click scroll
See Firefox Bug 984542 Bug 987011 and Bug 984037.

Probably Fixed on 2.33 by backing out Bug 938359.
Probably Fixed on 2.34 by Bug 984037 - general.autoScroll pref no longer respected
(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0 SeaMonkey/2.32
Build ID: 20141218225525

Steps to reproduce:

Set up preference "general.autoScroll" to "true" in about:config



Actual results:

Autoscrolling does not work.


Expected results:

After middle click to web page (or mailnews/feeds article) is not shown autoscroll icon and I can not scroll page with moving mouse up, or down, as before.

Work in SeaMonkey 2.31 and 2.34a1, does not work in 2.32b1 and 2.32b2 candidate builds.

(Both with new and commonly used SM profile.)

Comment 1

3 years ago
Confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

3 years ago
I just updated my Linux comm-beta build to 2.32 and it seems to be autoscrolling OK, but general.autoScroll might not be the only preference that I've changed.

Comment 3

3 years ago
Just tried a new Linux profile and turned autoscroll on and it's still OK for me.

Comment 4

3 years ago
Win Vista even same auto-scroll does not work

Updated

3 years ago
Duplicate of this bug: 1120138

Comment 6

3 years ago
User-Agent: Mozilla/5.0 (X11; Linux i686; rv:35.0) Gecko/20100101 Firefox/35.0 SeaMonkey/2.32
Build-Identifikator: 20150112202541

I just upgraded to 2.32 and I can confirm this. It was the first thing I noticed.

A clean profile does not help.

Comment 7

3 years ago
Same issue on Windows 7:
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 SeaMonkey/2.32

Comment 8

3 years ago
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 SeaMonkey/2.32
Build identifier: 20150112201917

Same here. No autoscroll after updating to 2.32
general.autoScroll is set to default (true)
Starting in Safe Mode does not help.

Updated

3 years ago
Duplicate of this bug: 1122069

Updated

3 years ago
Duplicate of this bug: 1122617

Comment 11

3 years ago
I never knew how much I use the middle mouse button to scroll, here at home and at work.
After two days I will go back to 2.31 right now, using the mouse wheel is not good for my carpal tunnels.
Hoping for a 2.32.1 version to fix this issue soon.
A very rare case where an SM update did something bad compared to other Mozilla products.

Comment 12

3 years ago
Regression window: 20141008 - http://hg.mozilla.org/mozilla-central/rev/e4cfacb76830 to 20141012 - http://hg.mozilla.org/mozilla-central/rev/44168a7af20d (archive.m.o sadly doesn't have any SeaMonkey trunk builds in between those two) - https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e4cfacb76830&tochange=44168a7af20d
4 commit messages mentioning "scroll" in their description in that time window: bug 1074165, bug 1078316, bug 1078373 and bug 1076447; the last three are FxOs, so the first of those might be worth a closer look?

Updated

3 years ago
Keywords: regression

Comment 13

3 years ago
Autoscroll works in 2.33a2 aurora build 20150108013001 and in the current nightly so it looks like this is fixed there. Does this mean the fix will propagate to 2.33 final? If that is the case then perhaps there is nothing to be done here other than wait for the next release - unless 2.32.1 is planned...

Updated

3 years ago
Duplicate of this bug: 1123256
Keywords: relnote

Updated

3 years ago
Summary: general.autoScroll not work in 2.32 beta → general.autoScroll does not work in 2.32

Updated

3 years ago
Duplicate of this bug: 1123348

Comment 16

3 years ago
Changing general.autoscroll to true or false has no effect in Seamonkey 2.32 at 64bit Win 7. Does not work. 
In Firefox (Win 7) it works.

At OpenSUSE 13.2 it works in Seamonkey and Firefox.

Comment 17

3 years ago
Possible related bugs:
Firefox Bug 984037 - general.autoScroll pref no longer respected
Firefox Bug 938359 - [e10s] Support middle-click scroll
Using "Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 SeaMonkey/2.32" under Kubuntu 14.10, autoscroll doesn't work. In 2.31b1, it did. In today's trunk, it does.

Comment 19

3 years ago
Unfortunately still not fixed in the recent 2.32.1.
(Reporter)

Comment 20

3 years ago
It seems that this bug has already been fixed (at least in the x86_64 linux version of seamonkey-2.33b1.tar.bz2)...
I thank all those who are responsible for it!
It also works for me in 2.33b1 on Windows, while it was broken in all 2.32 releases (including betas).

This bug is about 2.32 only. Since 2.32 won't be fixed but later versions are OK, I'll mark this WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX

Updated

3 years ago
User Story: (updated)
Whiteboard: [wontfix for 2.32; fixed in 2.33 by a combination of Bug 984037 and/or backing out Bug 938359 ([e10s] Support middle-click scroll)
You need to log in before you can comment on or make changes to this bug.