[NFC][Contact] Could not share contacts via NFC

VERIFIED FIXED in 2.2 S3 (9jan)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ashiue, Assigned: allstars.chh)

Tracking

unspecified
2.2 S3 (9jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Posted file nfc.log
Gaia-Rev        ca6e91e09ef3ab417a0f6b6d6668d43597d85700
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/7b33ee7fd162
Build-ID        20141221160205
Version         37.0a1
Device-Name     flame

STR:
1. launch "settings" app for 2 phones
2. turn on "NFC" for 2 phones
3. device A(2.2) share contact via NFC to device B 

Expected result:
device B receive contact successfully

Actual result:
device B receive nothing and contacts app in device A has been killed
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.2?
QA Whiteboard: [COM=NFC]
Assignee: nobody → allstars.chh
Blocks: b2g-nfc
Blocks: NFC-Gaia
No longer blocks: b2g-nfc
Posted file Gaia Pull Request
Hi, Alive and Francisco

For using MozNFCPeer.sendNDEF, it needs 'nfc' permission, so this patch is to add 'nfc' permission to System app and Contacts app.

Could you help to review this?

Thanks.
Attachment #8539937 - Flags: review?(francisco)
Attachment #8539937 - Flags: review?(alive)
Comment on attachment 8539937 [details] [review]
Gaia Pull Request

r=me, are we having this documented on MDN?
Attachment #8539937 - Flags: review?(alive) → review+
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #2)
> Comment on attachment 8539937 [details] [review]
> Gaia Pull Request
> 
> r=me, are we having this documented on MDN?
I have started updating MDN but not finish yet.
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1112919
function broken
blocking-b2g: 2.2? → 2.2+
Attachment #8539937 - Flags: review?(francisco) → review+
https://github.com/mozilla-b2g/gaia/commit/dd23a7b904dd93fdeb399b34822d389d7b3ddc3b
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

4 years ago
Verified on
Gaia-Rev        c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/636498d041b5
Build-ID        20150104160203
Version         37.0a1
Status: RESOLVED → VERIFIED
Target Milestone: --- → 2.2 S3 (9jan)
You need to log in before you can comment on or make changes to this bug.