Closed Bug 1114476 Opened 5 years ago Closed 5 years ago

[DT][Privacy]change Privacy Panel to a meaningful word

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S6 (20feb)
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: gasolin, Assigned: gasolin)

References

Details

(Keywords: privacy)

Attachments

(2 files)

Privacy Panel is a too general word, 
I can't understand what Privacy Panel/Browsing Privacy/Do not track denotes.

Maybe we could change 'Privacy Panel' to 'Location & Remote' or something really help users to check them.
@jenny please suggest a good name once you have the bandwidth, thanks!
Flags: needinfo?(jelee)
Hi Fred,
I agree the naming is a little confusing. Let's involve UX designer from DT as Privacy panel is their topic.
Thanks for pointing that out!

Hi Wesley,
Could you kindly help adding UX designer from DT for this bug? Thanks!
Flags: needinfo?(jelee) → needinfo?(whuang)
[NI to Wilfred as he's the contact window to partner]
[NI to Josh who will be the EPM for privacy feature]
Flags: needinfo?(wmathanaraj)
Flags: needinfo?(whuang)
Flags: needinfo?(jocheng)
Blocks: Privacy
Flags: needinfo?(jocheng)
Keywords: privacy
Summary: change Privacy Panel to a meaningful word → [DT][Privacy]change Privacy Panel to a meaningful word
I think we have had extensive discussions about the naming of this feature contribution. I have added Alina from our Privacy team and MArta from DT side to comment further. But I dont think this is something we should focus on for 2.2.
Flags: needinfo?(wmathanaraj)
Flags: needinfo?(marta)
Flags: needinfo?(ahua)
The privacy panel was meant as a combination of all privacy settings, something that will grow with time to combine more features. I do agree that it would make sense to merge all of it together.
Flags: needinfo?(marta)
@marta, do you have suggestion for v2.2 (or future version) to make current settings list looks more meaningful to end user?
Flags: needinfo?(marta)
Privacy Controls? Putting in the loop other DT people.
Flags: needinfo?(marta)
Flags: needinfo?(louis.schreier)
Flags: needinfo?(bugzilla)
'Privacy controls' +1!

According to https://wiki.mozilla.org/Release_Management/FirefoxOS/2_2_Schedule , for 2.2 most strings should have landed by 2015/02/23, so we'd better come out the decision on time.
QA Whiteboard: [COM=Privacy Panel]
Is anyone from like to comment about the naming here? 
Do we really want to rename Privacy Panel on 2.2?
@jenny if you think 'Privacy controls' is good to go, I could provide PR for this issue.
Flags: needinfo?(jelee)
I'm afraid "Privacy controls" will be truncated on the homescreen App icon. Has anyone checked?
Yea sure, let's go!
Flags: needinfo?(jelee)
@theo I think privacy panel does not shown on the homescreen App anymore (at least on master), but only accessible via settings.
Assignee: nobody → gasolin
Status: NEW → ASSIGNED
Comment on attachment 8561251 [details] [review]
[PullReq] gasolin:issue-1114476 to mozilla-b2g:master

Naming changed from `Privacy Panel` to `Privacy Controls`. The change only affect on wording inside the app and the settings, but not the module name.

also set ui review to @jenny
Attachment #8561251 - Flags: ui-review?(jelee)
Attachment #8561251 - Flags: review?(marta)
Attachment #8561251 - Flags: review?(arthur.chen)
Comment on attachment 8561251 [details] [review]
[PullReq] gasolin:issue-1114476 to mozilla-b2g:master

looks good =)
Attachment #8561251 - Flags: ui-review?(jelee) → ui-review+
Comment on attachment 8561251 [details] [review]
[PullReq] gasolin:issue-1114476 to mozilla-b2g:master

Please also change the string id when changing a string, thanks.
Attachment #8561251 - Flags: review?(arthur.chen)
Comment on attachment 8561251 [details] [review]
[PullReq] gasolin:issue-1114476 to mozilla-b2g:master

Thanks for notice! changed string id and make sure they looks fine on device.

Please kindly review it again.
Attachment #8561251 - Flags: review?(arthur.chen)
Comment on attachment 8561251 [details] [review]
[PullReq] gasolin:issue-1114476 to mozilla-b2g:master

The code looks good to me. Let's wait for the inputs from DT people.
Attachment #8561251 - Flags: review?(arthur.chen) → review+
Attachment #8561251 - Flags: review?(marta) → review+
merged https://github.com/mozilla-b2g/gaia/commit/b077b97eead06bac34a7ba95eb2d77650a97ee2b

thanks!
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(louis.schreier)
Flags: needinfo?(bugzilla)
Flags: needinfo?(ahua)
Resolution: --- → FIXED
Comment on attachment 8561251 [details] [review]
[PullReq] gasolin:issue-1114476 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1057675 ([meta]privacy_panel)
[User impact] if declined: User will see Privacy panel instead of Privacy controls, which is not meaningful to users
[Testing completed]: Treeherder green
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: yes
Attachment #8561251 - Flags: approval-gaia-v2.2?
Attachment #8561251 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Target Milestone: --- → 2.2 S6 (20feb)
This didn't completely removed all occurrences of privacy panel…
stefan could you help point out where the 'occurrences' are, so we could fix it.
Flags: needinfo?(splewako)
@stefan it's intended because the error message or the description are not usually seem by user. I think it worth to keep them as a clue for developer since the module name in gaia folder is still 'apps/privacy-panel'.
The reasoning here seems so wrong that I'm reopening this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
As comment 27, I think it's not make sense to reopen this bug.
If you feel it's the bug, please open a follow up issue and nominate it.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
(In reply to Fred Lin [:gasolin] from comment #27)
> @stefan it's intended because the error message or the description are not
> usually seem by user. I think it worth to keep them as a clue for developer
> since the module name in gaia folder is still 'apps/privacy-panel'.

Error messages are for users, debugging is for developers, source code comments are clues for developers and this bug was solely about renaming Privacy Panel to something meaningful for users.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Blocks: 1141971
@Stefan REOPEN bug means we would backout the commit, I think it's not the purpose you want to achieve.

I've fired bug 1141971 that aim to fix the remain wording. Hope it serves your purpose well.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
(In reply to Fred Lin [:gasolin] from comment #31)
> @Stefan REOPEN bug means we would backout the commit, I think it's not the
> purpose you want to achieve.

No, it means „This bug was once resolved, but the resolution was deemed incorrect”, https://bugzilla.mozilla.org/page.cgi?id=fields.html#status and for sure it doesn't define how to accomplish agreement and correct resolution.

> I've fired bug 1141971 that aim to fix the remain wording. Hope it serves
> your purpose well.

OK, fine.
You need to log in before you can comment on or make changes to this bug.