The settings page will become unresponsive after long press on any item when the text selection mode is triggered once

RESOLVED DUPLICATE of bug 1112031

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1112031
3 years ago
3 years ago

People

(Reporter: gchang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
### Steps:
1. Open Settings app
2. Navigate to Wi-Fi > Manage Networks > Join Hidden Network
3. Type some characters in the SSID input field (ex: 12345)
4. Long press the character to trigger the cut/copy/paste menu
5. Tap "X" in the upper-left corner to exit the current page
6. Go back to Settings page
7. Long press on "SIM Manager" item or any item (The item will be highlighted)
8. Scroll the whole settings page

### Expected:
1. User is able to scroll the whole settings page

### Actual:
1. User can't scroll the any page in Settings app

### Reproduce rate
always

### Version:
Gaia-Rev        ca6e91e09ef3ab417a0f6b6d6668d43597d85700
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/7b33ee7fd162
Build-ID        20141221160205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
(Reporter)

Updated

3 years ago
Blocks: 1023688
QA Whiteboard: [textselection]
I could simplify the steps as follows:
1. Open Settings app
2. Navigate to Wi-Fi > Manage Networks > Join Hidden Network
3. Tap "X" in the upper-left corner to exit the current page
4. Go back to Settings page
5. Scroll the whole settings page

i.e: skip 3, 4, 7 step.

I also disable touch/selection carets preference and test again. The issue still happened.
So I don't think this is related to copy/paste feature.

Looks like this is a duplicate bug of bug 1112031?
See Also: → bug 1112031

Comment 2

3 years ago
ni Gerry if this bug still exist? If so, can you try to turn off the text selection to see the result? Thanks.
Flags: needinfo?(gchang)
(Reporter)

Comment 3

3 years ago
The issue doesn't exist in 
Gaia-Rev        c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/636498d041b5
Build-ID        20150104160203
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
Flags: needinfo?(gchang)

Comment 4

3 years ago
Gerry, please close the case if you can't reproduce it again or mark as a duplicate.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1112031
(Reporter)

Updated

3 years ago
QA Whiteboard: [textselection] → [COM=Text Selection]
You need to log in before you can comment on or make changes to this bug.