[Flame][Homescreen]The "OK", "Close" and "back" button can't be displayed.

VERIFIED FIXED in 2.2 S4 (23jan)

Status

defect
--
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: liuke, Assigned: mancas)

Tracking

({regression})

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(7 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v2.2][Homescreen]The "OK", "Close" and "back" button can't be displayed on "Operator message" page.
Found time:15:19
See attachment:compare.png and logcat_1519.txt

[2.Testing Steps]: 
1.Install CU SIM to device.
2.Turn on device.
3.When device display "Operator message".

[3.Expected Result]: 
3.All button should be displayed.

[4.Actual Result]: 
3.The Operator message page can't display "OK", "Close" and "back" button.

[5.Reproduction build]: 
Gaia-Rev        ca6e91e09ef3ab417a0f6b6d6668d43597d85700
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/7b33ee7fd162
Build-ID        20141221040207
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: Free Test
(Reporter)

Comment 1

4 years ago
Posted image compare.png
(Reporter)

Comment 2

4 years ago
Posted file logcat_1519.txt
Hi EJ, Could you help with this? Or do you know anyone who can help? Same dialog without those buttons in STK also happened.
Flags: needinfo?(ejchen)
Alive, it seems that operator message is captured by System app instead off Settings app, do you know who is the better person to check this issue (?)
Flags: needinfo?(ejchen) → needinfo?(alive)
I guess this is STK but I am not sure. Fernando could you confirm?
Flags: needinfo?(alive) → needinfo?(ferjmoreno)
Yes, looking at the RIL logs attached here this looks like STK stuff. But let's ask to other Fernando who owns the STK code and can probably tell better than me :)
Flags: needinfo?(ferjmoreno) → needinfo?(frsela)
Thank you Fernando. We'll fix this.
Assignee: nobody → b.mcb
Flags: needinfo?(frsela)
(Assignee)

Comment 8

4 years ago
Posted file Proposed patch
Tim, I've changed the look&feel of this dialog in order to set the same style in the whole system.

Notice that the "back" word is not displayed anymore.

Thanks
Attachment #8545878 - Flags: review?(timdream)
(Assignee)

Comment 9

4 years ago
Posted image stk icon.png
(Assignee)

Comment 10

4 years ago
Also notice that the option menu will be fixed once we land bug 111706
It would be better if we could link this bug to the regressed bug.

Set 2.2? for regression.
Status: NEW → ASSIGNED
blocking-b2g: --- → 2.2?
Component: Gaia::Homescreen → Gaia::System
Keywords: regression
(Assignee)

Comment 12

4 years ago
(In reply to Manuel Casas Barrado [:mancas] from comment #10)
> Also notice that the option menu will be fixed once we land bug 111706

Bug 1117066. Sorry for the inconvenience
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/697e3c14048c10b8d062ed103ce760c80f479ccd
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S4 (23jan)
Please request Gaia v2.2 approval on this when you get a chance :)
Flags: needinfo?(b.mcb)
QA Whiteboard: [COM=Gaia::System]
(Assignee)

Comment 15

4 years ago
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):Bug 1117066
[User impact] if declined: Back button will not be displayed
[Testing completed]: Manual test
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: No
Flags: needinfo?(b.mcb)
Attachment #8551150 - Flags: approval-gaia-v2.2?
Attachment #8551150 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Comment 17

4 years ago
Posted image verify.png
This issue has been verified successfully on Flame 2.2/3.0, the "OK" and "Close" buttons are displayed normally at Operator message view.
See attachment:verify.png
Rate:0/5

Flame 2.2 build:
Build ID               20150214002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6de30e6bbc84
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.044811
Firmware Date          Sat Feb 14 04:48:22 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150214010227
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a7c177546ca0
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.043959
Firmware Date          Sat Feb 14 04:40:10 EST 2015
Bootloader             L1TC000118D0

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Gaia::System] → [COM=Gaia::System][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.