When FOTA update fail, phone should show a messag and reboot

RESOLVED DUPLICATE of bug 1212884

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 1212884
4 years ago
3 years ago

People

(Reporter: dattaz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8540204 [details]
IMG_20141222_173254.jpg

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20141221030204

Steps to reproduce:

Made a fail OTA , phone download it, and reboot to install it


Actual results:

Phone can't install it for any reason.(signature fail in this exemple - see attach file)
Phone show recovery and wait user type reboot with power bouton


Expected results:

Phone should show why update fail and reboot. But not in recovery interface which scares someone who didn't what is it (and potentially made bad action)
Edify itself is very limited. I'm not sure it's worth the complexity, and I think it's better to scare people :).

At least, this way they know something bad happened and they can take note/pictures, so we can debug.
Flags: needinfo?(gsvelto)
Yes, there's not much we can do. We might print a more detailed message using ui_print() but that's about it. AFAIK there's no way to reboot the phone from within an edify script. There's the run_program() command available which we use for accessing `touch' and `mv' from the update script. We might use that to try and reboot the phone but there's no guarantee it will work as I'm not sure if we have access to the reboot binary from the recovery partition (nor I know if we would reboot in normal mode rather than in recovery mode).
Flags: needinfo?(gsvelto)
After having done a little more investigation I've found out that if we could call `reboot' we could indeed restart the phone in normal mode. However I'm not sure that directly invoking the `reboot' command in an edify script is a good idea. Existing code does some cleanup before rebooting the system independently of whether it succeeded or not. We'd probably need to duplicate that stuff in our edify script before rebooting which would make it messy and fragile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1212884
You need to log in before you can comment on or make changes to this bug.