MSE MP4 Video crashes when reaching the end of playback and restarting

RESOLVED DUPLICATE of bug 1114849

Status

()

P1
normal
RESOLVED DUPLICATE of bug 1114849
4 years ago
4 years ago

People

(Reporter: cajbir, Unassigned)

Tracking

(Blocks: 1 bug)

33 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Possibly related to bug 1114844? Steps to reproduce:

1) Enable MP4 mediasource playback and disable WebM mediasource playback.
   media.mediasource.mp4.enabled = true
   media.mediasource.webm.enabled = false
   media.fragmented-mp4.exposed = true
   media.fragmented-mp4.ffmpeg.enabled = true
2) Go to video (I used http://www.youtube.com/watch?v=3V7wWemZ_cs)
3) Start playback
4) Right click and view stats for nerds to confirm that MP4 Dash is used
5) Wait for playback to complete
6) Click play button again to restart video

What happens:

6) Tab crashes

What should happen:

6) Playback of video starts from beginning
(Reporter)

Updated

4 years ago
Blocks: 778617
Thanks for reporting. Can you kindly provide the crash report by typing about:crashes in the URL bar?
Flags: needinfo?(cajbir.bugzilla)
(Reporter)

Comment 2

4 years ago
Unfortunately I don't get crash reports in my builds and I wasn't able to get a relevant stack trace from gdb.
Flags: needinfo?(cajbir.bugzilla)
same as bug 1114849, will be fixed with landing of 1115749
Depends on: 1115749
(Reporter)

Comment 4

4 years ago
Confirmed that this no longer crashes.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1114849
You need to log in before you can comment on or make changes to this bug.