Closed Bug 1114849 Opened 5 years ago Closed 5 years ago

MSE MP4 Video crashes when seeking

Categories

(Core :: Audio/Video, defect, P1)

33 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: cajbir, Unassigned)

References

(Blocks 1 open bug)

Details

Possibly related to bug 1114844 and bug 1114847. Steps to reproduce:

1) Enable MP4 mediasource playback and disable WebM mediasource playback.
   media.mediasource.mp4.enabled = true
   media.mediasource.webm.enabled = false
   media.fragmented-mp4.exposed = true
   media.fragmented-mp4.ffmpeg.enabled = true
2) Go to video (I used http://www.youtube.com/watch?v=3V7wWemZ_cs)
3) Start playback
4) Right click and view stats for nerds to confirm that MP4 Dash is used
5) Seek somewhere in the video

What happens:

6) Tab crashes

What should happen:

6) Playback of video continues from seeked point.
Blocks: MSE
If this is the same as what I'm seeing: MoofParser::Moofs { mMonitor->AssertCurrentThreadOwns(); }
This should be fixed once bug 1115749 land.
Depends on: 1115749
This is no longer crashing for me.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1114847
You need to log in before you can comment on or make changes to this bug.