Bug 1114866 (hausa-keyboard)

Request to add Hausa (ha) keyboard to Firefox OS - multiple branches

RESOLVED WONTFIX
(Needinfo from 2 people)

Status

Firefox OS
Gaia::Keyboard
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: delphine, Assigned: rudyl, NeedInfo)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

Attachments

(3 attachments)

46 bytes, text/x-github-pull-request
timdream
: review+
rudyl
: feedback?
arky
Details | Review | Splinter Review
288.54 KB, application/x-zip-compressed
Details
10.06 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
Request to add Hausa (ha) locale to Firefox OS.
[Blocking Requested - why for this release]:
Requested for 2.0 and onwards. Thus nominating
blocking-b2g: --- → 2.0?
Flags: needinfo?(bbajaj)
Blocks: 1112982
[Blocking Requested - why for this release]:

[Triage] Considering current 2.0 timing and the need from partner, nom. to 2.1 (or even 2.2?) instead for consideration.
blocking-b2g: 2.0? → 2.1?
Clearing the nom as we still need confirmation from BD/product team on which release this locale is targeted for. Delphine will re-nom accordingly once we get more details.
blocking-b2g: 2.1? → ---
Flags: needinfo?(bbajaj)
Added Hausa localizer to see if in the meantime, he can help on with keyboard and autcorrection (see Bug 1126076) input about this.
Marc Stephan: any feedback on what keyboard we should use? thanks
Flags: needinfo?(mcsteann)
Ok seems like Hausa localizer is not responding:
* Peiying: can you ask Rubric to give insight into this?
* Bruce: can you help drive this with keyboard team?
thanks all!
Flags: needinfo?(pmo)
Flags: needinfo?(bhuang)
This one is a bit tougher without local feedback.  I can try to put something together for the the Latin based boko, but the Arabic based ajami will be harder for me to figure out.
Adding to team backlog for now.
blocking-b2g: --- → backlog
Flags: needinfo?(bhuang)
+ Devon & Ian

Comment 8

3 years ago
This keyboard is confirmed complete: http://virtualkeyboard.biz/hausa
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
Is there anything else needed for this?
Hi Bruce: as per the mana, this is needed soon for partner request on 2.1 (with 2 other Nigerian locales). Comment 8 gives the local feedback needed. Could you please help drive this keyboard request forward?
Also, blocking 2.1 on this, as per mana
Thanks!
blocking-b2g: --- → 2.1+
tracking-b2g: backlog → ---
Flags: needinfo?(pmo) → needinfo?(bhuang)
Updated a layout here, had to tweak it from the link in comment 8 since we have limited room on screen.

https://drive.google.com/open?id=1S4ir2gz36BrP0Z-aUvl4vt4Nq8zGwRCD65acpKT2iIc&authuser=0

Rudy, can you take a look to see if you have any questions?
Flags: needinfo?(bhuang) → needinfo?(rlu)

Comment 12

3 years ago
Created attachment 8602010 [details] [review]
[gaia] RudyLu:keyboard/Bug1114866-Hausa_keyboard_layout > mozilla-b2g:master
Comment on attachment 8602010 [details] [review]
[gaia] RudyLu:keyboard/Bug1114866-Hausa_keyboard_layout > mozilla-b2g:master

The layout is ready in this patch.

Tim, could you please help review it?
Thanks.
Flags: needinfo?(rlu)
Attachment #8602010 - Flags: review?(timdream)
Assignee: nobody → rlu
Status: NEW → ASSIGNED
Comment on attachment 8602010 [details] [review]
[gaia] RudyLu:keyboard/Bug1114866-Hausa_keyboard_layout > mozilla-b2g:master

Arky,

We would need your feedback on this layout as well.
Thank you.
Attachment #8602010 - Flags: feedback?(hitmanarky)
Comment on attachment 8602010 [details] [review]
[gaia] RudyLu:keyboard/Bug1114866-Hausa_keyboard_layout > mozilla-b2g:master

Do we need dictionary for the layout?
Attachment #8602010 - Flags: review?(timdream) → review+

Comment 16

3 years ago
(In reply to Rudy Lu [:rudyl] from comment #14)
> We would need your feedback on this layout as well.
> Thank you.

@RudyLu Currently on a long trip to West Africa. Will try to provide feedback as soon as possible. 

Also to try to loop in Sakairu, a native Hausa speaker. I don't think he has a bugzilla account yet.
Arky: ok please do keep this on your radar, Nigerian languages are shipping really soon..
Created attachment 8607391 [details]
Hausa keyboard screenshots

Screenshots of Hausa keyboard including secondary characters.
Ian, Devon, could you confirm if the keyboard layouts in comment 18 are good to go?

Comment 20

3 years ago
Created attachment 8612235 [details]
Hausa keyboard layout.docx

Hi All, 

Our Hausa translator provided the below feedback regarding Hausa keyboard layout:

"The first keyboard (Hausa1.png) is the correct one for the one I'm using. But you should please note two things:
1. The position of the letter Ƙ is after the letter P in the position of left square bracket [  
2. Hausa language, to my knowledge, does not use the Y with a 'hook' as represented on Hausa2.png. (Please refer to my attachment). There are some Hausa words that are written with an apostrophe before the letter Y. But the apostrophe does not refer to possession as in the English writing system; it only represents a phoneme."

Please let us know if you have any questions.

Thank you,
Devon
Bruce, do you think we should be modify the spec, according to comment 20?
Thanks.
Flags: needinfo?(bhuang)
(In reply to Devon from comment #20)
> 
> "The first keyboard (Hausa1.png) is the correct one for the one I'm using.
> But you should please note two things:
> 1. The position of the letter Ƙ is after the letter P in the position of
> left square bracket [  

Unfortunately our mobile UI is cramped and adding an extra letter on the top row will make all the keys too small to type on.  That's why I tried to group the extra letters on to something that looked similar.  Is the letter Ƙ more common than that latin alphabet K?  If so, we can reverse and have K be the secondary.

> 2. Hausa language, to my knowledge, does not use the Y with a 'hook' as
> represented on Hausa2.png. (Please refer to my attachment). There are some
> Hausa words that are written with an apostrophe before the letter Y. But the
> apostrophe does not refer to possession as in the English writing system; it
> only represents a phoneme."

I referenced the link provided in comment 8: http://virtualkeyboard.biz/hausa, and http://en.wikipedia.org/wiki/Hausa_language#Boko_.28Latin.29 or http://www.omniglot.com/writing/hausa.htm showing that this letter is used.  Can you help review the links as well?

Thanks!
Flags: needinfo?(bhuang)
Flags: needinfo?(devon.bezuidenhout)

Comment 23

2 years ago
Hi All,

We have received the following feedback from our Hausa translator:

I referred to the links you're talking about, and I saw the letter you are referring to. However, I still maintain my position that the letter does not exist because you will never see any Hausa textbook, novel, journal or newspaper that use the letter in Hausaland. Maybe I can agree with you that phoneticians can use it to refer to a phonetic symbol as we have for the English language which phonetically has 24 vowels and several consonant sounds. 

Please let me know if you have any questions.

Thanks,
Devon
Flags: needinfo?(devon.bezuidenhout) → needinfo?(lebedel.delphine)
Thanks Devon! Comment 23 seems to clarify things.
Wilfred: can you please find someone who can take over and move ahead with this? Seems Rudy is no longer here. thanks
Flags: needinfo?(lebedel.delphine) → needinfo?(wmathanaraj)

Comment 25

2 years ago
[Blocking Requested - why for this release]:

Hi Vance,
Do we still need this for 2.1/2.1S? Should we make this 2.5+?
Thanks!
blocking-b2g: 2.1+ → 2.5?
Flags: needinfo?(vchen)
We don't need this for 2.1/2.1s, let's make it 2.5+ instead
Flags: needinfo?(vchen)
Alias: hausa-keyboard
Wilfred, 

Can you please confirm if this is required for 2.5 ?

Thanks
[Tracking Requested - why for this release]:

Clearing the nom as we still need confirmation from BD/product team on which release this locale is targeted for. Delphine will re-nom accordingly once we get more details.
blocking-b2g: 2.5? → ---
tracking-b2g: --- → backlog
Flags: needinfo?(wmathanaraj) → needinfo?(aaime)
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.