[FFOS2.0][Woodduck] If the same activity window is launched twice, the second one can't change its view properly

RESOLVED DUPLICATE of bug 931339

Status

Firefox OS
Gaia::System
P2
normal
RESOLVED DUPLICATE of bug 931339
3 years ago
3 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0M?, b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(7 attachments)

(Reporter)

Description

3 years ago
DEFECT DESCRIPTION:
 KO2:MS can't enter to the contact detail but Contact list.
 KO3:MS can't enter to new sms to the selected contact but SMS conversation list.
 
  REPRODUCING PROCEDURES:
 1.Go to SMS,send a sms with the recepient number (e.g)10086 in the content to one number (e.g)10086;
 2.Add 10086 to Contact;
 3.Go to SMS,touch the sms Contact in the top line->View contact--KO2.
 4.Go to Contact->view this contact(10086)->Touch the send sms icon to send sms--KO3;
 
 >If you don't reproduce,you can redo step3&4.
 
  EXPECTED BEHAVIOUR:
 KO2:MS can enter to contact detail from SMS.
 KO3:MS can enter to new sms of the selected contact interface.
 
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:2611692(61692).
(Reporter)

Comment 1

3 years ago
Created attachment 8540593 [details]
850431mtklog.rar

Comment 2

3 years ago
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Please NI back when you done. Thanks!
Blocks: 1054172
blocking-b2g: --- → 2.0M?
Flags: needinfo?(fan.luo)
Keywords: qawanted
(Reporter)

Comment 3

3 years ago
(In reply to comment #1)
 > Comment from Mozilla:Hi Norry,
 > qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
 > Please NI back when you done. Thanks!
 > 
 
 Sorry, I'm not understand, what should I do for you?
Created attachment 8541425 [details]
Flame2.2 logcat

Hi Hubert,
The problem can be repro on Flame 2.2 and can NOT repro on Woodduck2.0/Flame2.0/Flame2.1. 
See attachment: Flame2.2_logcat1453.txt & Flame2.2_video.MP4
Repro time: 14:53	
Occurrence rate: 4/5

Woodduck 2.0 new build:
Gaia-Rev        add38992bbfb2bafca52ac1ce7f6231ac702675f
Gecko-Rev       8d951d9c4988e218ec08c6118a35c7faeb70af49
Build-ID        20141225143517
Version         32.0

Flame 2.0 build:
Gaia-Rev        ce83ea7b8e3fa2d1c3fd771fc22b654c18b3c381
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/4dd6d9b58f42
Build-ID        20141224000204
Version         32.0

Flame 2.1 build:
Gaia-Rev        17c7ad2e4919a994f0844239b483116090412dee
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/39dfb662c82a
Build-ID        20141224001203
Version         34.0

Flame 2.2 build:
Gaia-Rev        cb1dad4881533bff9f06d47e34983c7b10c04a8c
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/b17e7747d3fb
Build-ID        20141224010204
Version         37.0a1
Flags: needinfo?(fan.luo) → needinfo?(hlu)
Created attachment 8541426 [details]
Flame2.2 video
Keywords: qawanted
status-b2g-v2.0: --- → unaffected
status-b2g-v2.0M: --- → unaffected
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected

Comment 6

3 years ago
Hi Reporter,
We cannot repo this issue on our side. Can you try repo the issue with Mozilla Gaia/Gecko? Thanks!

User build image link is: http://pan.baidu.com/s/1hqnDBtM
Access code: 9c9u
unzip password: erT14moz
Flags: needinfo?(hlu) → needinfo?(sync-1)
(Reporter)

Comment 7

3 years ago
Created an attachment (id=1093716)
 repo vedio in mozilla version
 
 Hi guys,
   I can repo this issue in the version your upload.Please check the vedio.The key-point is that after two MozActivities(contacts,sms) calls each other several times, Activity will stay in list page rather than jump to contact detail page or sms's edit page.
 
 1.Open contact,view contact(10010)
 2.click sms icon to send sms->jump to sms edit page-> OK
 3.send sms -> click contact title to view contact ->jump to contact detail page-> OK
 4.click sms icon to send sms again->jump to sms list page and stay -> KO1
 5.click one sms to edit->click contact title to view contact->jump to contact list page and stay -> KO2
 
 KO1:should jump to sms edit page.
 KO2:should jump to contact detail page.
 
 Any confusion please let me know,Thanks!
(Reporter)

Comment 8

3 years ago
Created an attachment (id=1093716)
 repo vedio in mozilla version
 
 Hi guys,
   I can repo this issue in the version your upload.Please check the vedio.The key-point is that after two MozActivities(contacts,sms) calls each other several times, Activity will stay in list page rather than jump to contact detail page or sms's edit page.
 
 1.Open contact,view contact(10010)
 2.click sms icon to send sms->jump to sms edit page-> OK
 3.send sms -> click contact title to view contact ->jump to contact detail page-> OK
 4.click sms icon to send sms again->jump to sms list page and stay -> KO1
 5.click one sms to edit->click contact title to view contact->jump to contact list page and stay -> KO2
 
 KO1:should jump to sms edit page.
 KO2:should jump to contact detail page.
 
 Any confusion please let me know,Thanks!
(Reporter)

Comment 9

3 years ago
Created attachment 8542377 [details]
repo vedio in mozilla version

Created an attachment (id=1093716)
 repo vedio in mozilla version
 
 Hi guys,
   I can repo this issue in the version your upload.Please check the vedio.The key-point is that after two MozActivities(contacts,sms) calls each other several times, Activity will stay in list page rather than jump to contact detail page or sms's edit page.
 
 1.Open contact,view contact(10010)
 2.click sms icon to send sms->jump to sms edit page-> OK
 3.send sms -> click contact title to view contact ->jump to contact detail page-> OK
 4.click sms icon to send sms again->jump to sms list page and stay -> KO1
 5.click one sms to edit->click contact title to view contact->jump to contact list page and stay -> KO2
 
 KO1:should jump to sms edit page.
 KO2:should jump to contact detail page.
 
 Any confusion please let me know,Thanks!
(Reporter)

Comment 10

3 years ago
Created an attachment (id=1093716)
 repo vedio in mozilla version
 
 Hi guys,
   I can repo this issue in the version your upload.Please check the vedio.The key-point is that after two MozActivities(contacts,sms) calls each other several times, Activity will stay in list page rather than jump to contact detail page or sms's edit page.
 
 1.Open contact,view contact(10010)
 2.click sms icon to send sms->jump to sms edit page-> OK
 3.send sms -> click contact title to view contact ->jump to contact detail page-> OK
 4.click sms icon to send sms again->jump to sms list page and stay -> KO1
 5.click one sms to edit->click contact title to view contact->jump to contact list page and stay -> KO2
 
 KO1:should jump to sms edit page.
 KO2:should jump to contact detail page.
 
 Any confusion please let me know,Thanks!
(Reporter)

Comment 11

3 years ago
Created an attachment (id=1093716)
 repo vedio in mozilla version
 
 Hi guys,
   I can repo this issue in the version your upload.Please check the vedio.The key-point is that after two MozActivities(contacts,sms) calls each other several times, Activity will stay in list page rather than jump to contact detail page or sms's edit page.
 
 1.Open contact,view contact(10010)
 2.click sms icon to send sms->jump to sms edit page-> OK
 3.send sms -> click contact title to view contact ->jump to contact detail page-> OK
 4.click sms icon to send sms again->jump to sms list page and stay -> KO1
 5.click one sms to edit->click contact title to view contact->jump to contact list page and stay -> KO2
 
 KO1:should jump to sms edit page.
 KO2:should jump to contact detail page.
 
 Any confusion please let me know,Thanks!
(Reporter)

Comment 12

3 years ago
Created attachment 8542381 [details]
repo vedio in mozilla version

Created an attachment (id=1093716)
 repo vedio in mozilla version
 
 Hi guys,
   I can repo this issue in the version your upload.Please check the vedio.The key-point is that after two MozActivities(contacts,sms) calls each other several times, Activity will stay in list page rather than jump to contact detail page or sms's edit page.
 
 1.Open contact,view contact(10010)
 2.click sms icon to send sms->jump to sms edit page-> OK
 3.send sms -> click contact title to view contact ->jump to contact detail page-> OK
 4.click sms icon to send sms again->jump to sms list page and stay -> KO1
 5.click one sms to edit->click contact title to view contact->jump to contact list page and stay -> KO2
 
 KO1:should jump to sms edit page.
 KO2:should jump to contact detail page.
 
 Any confusion please let me know,Thanks!
Created attachment 8542458 [details]
VideoVerify.MP4

Hi Josh,

I can repro this bug according to comment 12's STR on Woodduck 2.0M(both user & eng) &Flame 2.0/Flame 2.1(both user&eng)/Flame 2.2.

Attach: LogcatVerify_0557.txt & VideoVerify.mp4
Found time: 5:57
Rate: 10/10

Woodduck build:
Gaia-Rev        688e86b46229e3281beb22fd29f723724eda9df5
Gecko-Rev       bb95bcf5c2033a59b3261b93804151d1addb75eb
Build-ID        20141230050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1419887136
FW-Date         Tue Dec 30 05:05:59 CST 2014
------------------
Flame 2.0:
Gaia-Rev        01c32dcdc08b3c8fc8b3082870439fa2c1089f4f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/b41c344ed82d
Build-ID        20141229000235
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141229.033937
FW-Date         Mon Dec 29 03:39:48 EST 2014
Bootloader      L1TC000118D0
------------------
FLame2.1 build:
Gaia-Rev        73be51f998031f06db0cd660c0e388fa621c9f4c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ea426e47bfc4
Build-ID        20141229001204
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141229.035147
FW-Date         Mon Dec 29 03:51:58 EST 2014
Bootloader      L1TC000118D0
------------------
FLame2.2 build:
Gaia-Rev        bdedbaf9f18a43c091ede770407d68d38582fe29
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/8850aa0f5332
Build-ID        20141229010215
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141229.044350
FW-Date         Mon Dec 29 04:44:01 EST 2014
Bootloader      L1TC000118D0
Flags: needinfo?(jocheng)
Created attachment 8542459 [details]
logcatVerify_0557.txt
Blocks: 1080481
status-b2g-v2.0: unaffected → affected
status-b2g-v2.0M: unaffected → affected
status-b2g-v2.1: unaffected → affected
According to comment 13, KO1&KO2 can be 100% repro, but this bug:MS will pop up "unsent message", just can be repro after you repeat the STR several times.

Comment 16

3 years ago
Hi Luke,
Could you please help to check the problem? Thanks!
Flags: needinfo?(jocheng) → needinfo?(lchang)

Updated

3 years ago
Flags: needinfo?(sync-1)
After quick investigation, I found that this bug is caused because the activity object is dispatched to the first activity window incorrectly. That's why the second activity window will remain in the initial view.

I'll look into it further so keep the NI for reminder.
Per comment 12 and comment 17, I'd prefer changing its title and component accordingly.
Component: Gaia::Contacts → Gaia::System
Flags: needinfo?(lchang)
Summary: [FFOS2.0][Woodduck][SMS]MS will pop up "unsent message"when we try to send sms from content number which saved in Contact. → [FFOS2.0][Woodduck] If the same activity window is launched twice, the second one can't change its view properly
Hi Alive,

Per comment 17, do you have any idea about that? Thanks.
Flags: needinfo?(alive)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(alive)
Resolution: --- → DUPLICATE
Duplicate of bug: 931339
You need to log in before you can comment on or make changes to this bug.