Closed Bug 1115036 Opened 5 years ago Closed 5 years ago

Update el (Greek) locale for DOM Inspector

Categories

(Other Applications :: DOM Inspector, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: philip.chee, Assigned: philip.chee)

References

()

Details

Attachments

(3 files)

(Bug 957149 comment #20)
> (In reply to George Malamas from comment #19)
> > Philip, DOMi 2.0.15 currently published on AMO does not include the greek
> > translation, 
> > i had submitted in time here. 
> Please in future file a separate bug for your translation (one bug per
> issue).
> 
> > Is there any problem with the translation?
> Not that I know. IanN stopped work on DOMi 2.0.15 due to other priorities
> and I had to pick it up at the last minute. This was the first time for both
> of us managing a DOMi release and your translation and a few things fell
> between the cracks. Sorry about that.
Summary: Add el (Greek) locale for DOM Inspector → Update el (Greek) locale for DOM Inspector
Had to fix one error:

> processing c:/t1/hg/comm-central/mozilla/extensions/inspector/resources/locale/jar.mn
> Comparing el to en-US
> Entities in ./viewers/styleRules.dtd don't match:
>   In c:/t1/hg/comm-central/mozilla/extensions/inspector/resources/locale/el: (remove these keys from your localization)
>     toggleSelectedImportant.accesskey

But otherwise looks OK.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
George, attached is a build of DOMi 2.0.16pre with your el update. Can you test to see if everything is correct? Thanks.
Attachment #8540805 - Flags: feedback?(nightgeorgy)
Hi Philip, 
Thanks for this update.
Comparing my own build of DOMi 2.0.15 to DOMi 2.0.16pre, i noticed only the 
same difference you noticed in styleRules.dtd.
To make a clarification about this, i made this modification intentionally, 
just because the menu item "Toggle !important" is the only item in menu it's 
appeared without to have access key. Just for consistency reasons. 
I had mentioned this in the past, in some other thread here. 
Of course, this is not an orphan modification, because i made also the relevant 
modification in styleRules.xul (in en-US styleRules.dtd too, in the package i submitted). 
You can consider this as a small patch. 
So, other than that, i consider that the greek locale is ok, since it's fully 
tested and is ok in my own build of DOMi 2.0.15, i use personally. 

(In reply to Philip Chee from comment #0)
> (Bug 957149 comment #20)
> > (In reply to George Malamas from comment #19)
> > Please in future file a separate bug for your translation (one bug per
> > issue).
I can understand about this. 
I submitted my translation here because i could not find some other way to do it.
Also, in my opinion, a translation contribution for a project is not a bug, 
needing a report to be filed here.
So, i believe that for this excellent project should be an official way for 
localization, like as for many other projects. 
For example, something like babelzilla.

Thanks
Attached file install.rdf
Philip, in attachment i submitted my install.rdf, to get the el section.
> Comparing my own build of DOMi 2.0.15 to DOMi 2.0.16pre, i noticed only the 
> same difference you noticed in styleRules.dtd.
> To make a clarification about this, i made this modification intentionally, 
> just because the menu item "Toggle !important" is the only item in menu it's 
> appeared without to have access key. Just for consistency reasons. 

> I had mentioned this in the past, in some other thread here. 
> Of course, this is not an orphan modification, because i made also the relevant 
> modification in styleRules.xul (in en-US styleRules.dtd too, in the package i submitted). 
> You can consider this as a small patch. 

1. This will affect *all* localizations not just el.
2. Your change in styleRules.xul will break the other localizations that are already up to date. I cannot ship DOM Inspector with only el locale!
3. As such you really need to file a separate bug for this specific issue.

> So, other than that, i consider that the greek locale is ok, since it's fully 
> tested and is ok in my own build of DOMi 2.0.15, i use personally.

Thanks!
> I can understand about this. 
> I submitted my translation here because i could not find some other way to do it.
You can create a new bug. Anyone can do this. You can add an attachment to the bug. Anyone can do this. In future please submit you changes as a real patch preferably in Git patch format.

> Also, in my opinion, a translation contribution for a project is not a bug, 
> needing a report to be filed here.
True. How ever this is how it has always been done in DOMi.

> So, i believe that for this excellent project should be an official way for 
> localization, like as for many other projects.
> For example, something like babelzilla.
I too want to move localizations to babelzilla. However this requires the consensus of various stakeholders *including* the other translators. Please start a discussion in the L10n forum/mailing-list. Make sure all the affected translators are in agreement. Note you need to file a separate bug to track the move to babelzilla!
Comment on attachment 8540935 [details]
install.rdf

Please file your change in patch format! or at least indicate what has changed.
Hi Philip, 
I wish you a Happy New Year!
I'm sorry for delayed response, this was due to holidays. 

Well, let me make some clarifications. 
1. About this modification i made to styleRules.xul, to add an access key, 
of course i didn't mean DOMi to be published with only en-US/el locales! 
As i already mentioned, this is just a small patch i submitted, which if 
been accepted, then the other translators should be notified to update 
their locales. 
2. About the file install.rdf i uploaded here, it is just a complement 
of my translation, because it contains the el "em:localized" section and so 
it's not a matter of bug. 
The same way you got the greek locale from my first submission, you should 
also get the greek "em:localized" section from this file, to update the rc 
DOMi with the complete greek translation. 
3. About filing bug reports here for things which are not real bugs, it's not 
a good practice in my opinion. Doing so, bugzilla.mozilla.org will lose its 
actual meaning, to discuss cases of real bugs or suggestions for project 
improvements. 
4. About localization of DOMi, i'm not sure if i have permissions to start 
a discussion in the L10n forum or take any other initiative about this matter. 
Don't you think this is a responsibility of the author of this project? 
However, i can assure you that it's very easy for anyone to register a project 
on babelzilla! I say that because i have a good experience there, as a translator 
for Greek and as a developer (about 40 translations/1 extension for firefox). 
In case of such a movement to babelzilla, i believe the other translators can 
be informed easily about this, because they are in touch, since they already have 
updated their locales for the new version of DOMi. 
Moreover, in a place like babelzilla, DOMi will be localized to many more languages 
by the guys there, instead of only a few languages it has currently. 
It's an excellent project, the "Right hand" of any developer in unlimited cases and 
so, undoubtedly worths to be localized in many languages to being used easily by 
any one in the world!
Pushed to repository:
http://hg.mozilla.org/dom-inspector/rev/60242bd0c895
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.