[RTL][Homescreen] In RTL the homescreen icons/apps is not align properly

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
P1
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: psiphantong, Assigned: nefzaoui)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

Reporter

Description

5 years ago
Description:
In RTL the homescreen icons/apps is not align properly


Repro Steps:
1) Update a Flame to 20141223010202
2) Go to Homescreen or download app and than go to homescreen


Actual:
homescreen icons/apps is not align properly, display LTR


Expected:

homescreen icons/apps is align properly, display RTL


Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141223010202
Gaia: c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko: 0532f2509f3f
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Repro frequency:100%
See attached: screenshot,logcat
Reporter

Updated

5 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(dharris)

Comment 1

5 years ago
This issue is noticed after typing text in rocketbar as well. The results are left-aligned.
Reporter

Updated

5 years ago
Summary: [Homescreen] In RTL the homescreen icons/apps is not align properly → [RTL][Homescreen] In RTL the homescreen icons/apps is not align properly
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(dharris)
Assignee

Comment 2

5 years ago
Posted file PR to Github
Hey Chris,
How does that look?
Thanks!
Attachment #8545294 - Flags: feedback?(chrislord.net)
Comment on attachment 8545294 [details] [review]
PR to Github

I've left my comments on github - in short, this looks good - it'd be an r+ with the comments addressed and a test to make sure that RTL layout works as expected (preferably a marionette test, but a unit test would do).

You may also want to file a bug to reverse the app-grouping header controls in RTL layout.

Nice work :)
Attachment #8545294 - Flags: feedback?(chrislord.net) → feedback+
Decided during triage this morning that this would block 2.2
blocking-b2g: --- → 2.2?
Assignee

Updated

5 years ago
Duplicate of this bug: 1058692
Assignee

Comment 6

5 years ago
Comment on attachment 8545294 [details] [review]
PR to Github

Ok, ready for review \o/
Attachment #8545294 - Flags: ui-review?(swilkes)
Attachment #8545294 - Flags: review?(chrislord.net)
Priority: -- → P1
Blocking per RTL triage for 2.2
blocking-b2g: 2.2? → 2.2+

Comment 8

5 years ago
Sorry - from the screenshot attached to this bug, I can't see what's wrong. Can someone please clarify? I ask because we were no longer seeing homescreen layout bugs in Arabic as of about 2.1. Thanks.
Comment on attachment 8545294 [details] [review]
PR to Github

Mostly nits in the review, but the tests I think could do with a significant change, so this should go for another round or two. It's still ready for ui-review, so leaving that.
Attachment #8545294 - Flags: review?(chrislord.net)
Assignee

Comment 10

5 years ago
Comment on attachment 8545294 [details] [review]
PR to Github

Will be adding screenshots instead for ui-review.
Attachment #8545294 - Flags: ui-review?(swilkes) → review?(chrislord.net)
Assignee

Comment 11

5 years ago
Attachment #8553857 - Flags: ui-review?(swilkes)
Comment on attachment 8545294 [details] [review]
PR to Github

Excellent work :)
Attachment #8545294 - Flags: review?(chrislord.net) → review+
argh whoops, I thought the ui-review had passed already... If it doesn't pass, please reopen and I'll back this out.

Merged to master: https://github.com/mozilla-b2g/gaia/commit/21bf307d0fdbbcc346f565850a682f3463be7039
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Assignee

Comment 14

5 years ago
(In reply to Stephany Wilkes from comment #8)
> Sorry - from the screenshot attached to this bug, I can't see what's wrong.
> Can someone please clarify? I ask because we were no longer seeing
> homescreen layout bugs in Arabic as of about 2.1. Thanks.

Just saw this,
Issue: Icons are left-aligned in RTL.

(In reply to Chris Lord [:cwiiis] from comment #12)
> Comment on attachment 8545294 [details] [review]
> PR to Github
> 
> Excellent work :)

Thanks :)

Comment 15

5 years ago
Comment on attachment 8553857 [details]
verticalhome_rtl_ui.png

Great work. Thanks!
Attachment #8553857 - Flags: ui-review?(swilkes) → ui-review+
Assignee

Comment 16

5 years ago
Comment on attachment 8545294 [details] [review]
PR to Github

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): lack of RTL support
[User impact] if declined: icons left aligned, which is wrong per spec
[Testing completed]: Yes, device: Flame
[Risk to taking this patch] (and alternatives if risky): no risk, only RTL-related code is touched
[String changes made]: No string changes
Attachment #8545294 - Flags: approval-gaia-v2.2?
Attachment #8545294 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Assignee: nobody → nefzaoui
Target Milestone: --- → 2.2 S5 (6feb)

Comment 18

4 years ago
This issue has verified successfully on latest Flame 2.2/3.0.
Reproduce rate:0/5
Attachment:Verify_RTL_Homescreen.png

Flame 2.2 build:

Gaia-Rev        6e494f1d2676d231abba7dcc2e2822d1170d2d02
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5e6fac01a72f
Build-ID        20150129003432
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150129.042943
FW-Date         Thu Jan 29 04:29:53 EST 2015
Bootloader      L1TC000118D0

Flame 3.0 build:

Gaia-Rev        9d2378a9ef092ab1fc15c3a9f7fc4171aab59d57
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/6bfc0e1c4b29
Build-ID        20150129010239
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150129.043711
FW-Date         Thu Jan 29 04:37:21 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact] [MGSEI-Triage+]

Comment 19

4 years ago
You need to log in before you can comment on or make changes to this bug.