Closed Bug 1058692 Opened 5 years ago Closed 5 years ago

Apps in the grid should be right-aligned in RTL locales

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(ux-b2g:2.2, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1115104
ux-b2g 2.2
Tracking Status
b2g-v2.2 --- affected

People

(Reporter: nefzaoui, Unassigned)

References

Details

(Whiteboard: [rtl-meta][2.1-Arabic-RTL-bug-bash])

Attachments

(2 files)

5.91 MB, video/mp4
Details
81.23 KB, text/plain
Details
No description provided.
Blocks: gaia-rtl
Whiteboard: [2.1-Arabic-RTL-bug-bash]
Ahmed, UX will need detail on the expected layout. We can't determine a new spec from the description. Thanks!
ux-b2g: --- → 2.2
Flags: needinfo?(nefzaoui.ahmed)
Sure,

Currently, a incomplete line of apps in homescreen (which is usually the last one) starts from the left to the right, so the gap/empty space is on the right.
I was thinking if the apps ordering alignment starts from the right to the left in RTL.
After a second thought, this seems like a complementary change,
What do you think?
Flags: needinfo?(nefzaoui.ahmed)
Ah - got it. Fortunately, I cannot reproduce this on the current 2.1 builds. I DID used to see this on 2.0 however, and I remember what you mean. Let's resolve this as fixed for now and file a new one as necessary against current builds. Thanks Ahmed!
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Mass Edit: adding the [rtl-meta]
Whiteboard: [2.1-Arabic-RTL-bug-bash] → [rtl-meta]
Whiteboard: [rtl-meta] → [rtl-meta][2.1-Arabic-RTL-bug-bash]
Keywords: verifyme
Hi Swilkes,This issue still exist on Flame 2.2
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
Build-ID        20150118002501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
Reproduce rate  5/5
Decription:Currently, a incomplete line of apps in homescreen (which is usually the last one) starts from the left to the right, so the gap/empty space is on the right.The apps ordering alignment should starts from the right to the left in RTL.
refer to Attachment: VIDEO0252.mp4 and logcat.txt
Status: RESOLVED → REOPENED
Flags: needinfo?(swilkes)
Keywords: verifyme
Resolution: FIXED → ---
Attached video VIDEO0252.mp4
Attached file logcat.txt
Being tracked in Bug 1115104
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1115104
Removing the flag for me. The bug that was causing odd spaces to appear, and thus this bug to be filed in the first place, should have been fixed long ago. If it appears again, it's a regression.
Flags: needinfo?(swilkes)
You need to log in before you can comment on or make changes to this bug.