[Calendar][RTL] When adding an event to Calendar, the blue arrow will overlap the time, when adding the time of the event

VERIFIED FIXED in 2.2 S4 (23jan)

Status

P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: SalvadorR, Assigned: nefzaoui)

Tracking

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8540891 [details]
CalendarTime.png

Description:
When user adds an event in the Calendar app, the time of when the event starts will overlap the blue arrow when adjusting the time of when the event will start
   
Repro Steps:
1) Update a Flame device to BuildID: 20141223010202
2) Open Calendar app
3) Add an event
4) Observe the blue arrow where user can change the time of the event
  
Actual:
Blue arrow overlaps the time of the event
  
Expected: 
no overlap occurs
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141223010202
Gaia: c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko: 0532f2509f3f
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 3/3
See attached: Screenshot, Logcat
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(dharris)
Created attachment 8547217 [details] [review]
[PullReq] anefzaoui:bug-1115109 to mozilla-b2g:master
(Assignee)

Comment 2

4 years ago
Comment on attachment 8547217 [details] [review]
[PullReq] anefzaoui:bug-1115109 to mozilla-b2g:master

Please review?
Thanks!
Attachment #8547217 - Flags: review?(kgrandon)
(Assignee)

Updated

4 years ago
Assignee: nobody → nefzaoui
Status: NEW → ASSIGNED
Comment on attachment 8547217 [details] [review]
[PullReq] anefzaoui:bug-1115109 to mozilla-b2g:master

Miller - could I pass this review off to you?
Attachment #8547217 - Flags: review?(kgrandon) → review?(mmedeiros)
Comment on attachment 8547217 [details] [review]
[PullReq] anefzaoui:bug-1115109 to mozilla-b2g:master

LGTM. simple change and solves the problem.
Attachment #8547217 - Flags: review?(mmedeiros) → review+
Keywords: checkin-needed
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/27301

The pull request could not be applied to the integration branch. Please try again after current integration is complete.
(In reply to Autolander from comment #5)
> https://github.com/mozilla-b2g/gaia/pull/27301
> 
> The pull request could not be applied to the integration branch. Please try
> again after current integration is complete.

Cleared this up on IRC with Ahmed - but this is happening because Autolander can't land code when the tree is closed. I need to adjust the message in this case.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Keywords: verifyme

Comment 8

4 years ago
Hi Ahmed
This issue still exist on Flame 2.2
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
Build-ID        20150118002501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
Reproduce rate  5/5
Happen time     2:25
Refer to picture 2015-01-19-02-25-44.png and logcat.txt. 
Description:When user adds an event in the Calendar app, the time of when the event starts will overlap the blue arrow when adjusting the time of when the event will start.
Expected: 
no overlap occurs
Status: RESOLVED → REOPENED
Flags: needinfo?(nefzaoui)
Keywords: verifyme
Resolution: FIXED → ---

Comment 9

4 years ago
Created attachment 8551111 [details]
2015-01-19-02-25-44.png

Comment 10

4 years ago
Created attachment 8551112 [details]
logcat.txt
(Assignee)

Comment 11

4 years ago
Aware of this, and will be handled with a request to uplift.
Flags: needinfo?(nefzaoui)
:kaze, can this be uplift to 2.2 ?
Flags: needinfo?(fabien)
@Elie: please make sure that patches on master have actually landed on 2.2 before reopening a bug for 2.2. We are seeing a few cases where bugs are reopened, but it's just a matter of uplifting the patch from master to 2.2. Please take into account for next time as this creates too much noise otherwise. Thanks!
@Josh and Elie: can you make sure to communicate this out to Marigold testers please? thanks!
Flags: needinfo?(zikui.yang)

Comment 14

4 years ago
(In reply to Delphine Lebédel [:delphine - use need info] from comment #13)
> @Elie: please make sure that patches on master have actually landed on 2.2
> before reopening a bug for 2.2. We are seeing a few cases where bugs are
> reopened, but it's just a matter of uplifting the patch from master to 2.2.
> Please take into account for next time as this creates too much noise
> otherwise. Thanks!
> @Josh and Elie: can you make sure to communicate this out to Marigold
> testers please? thanks!

OK Thanks for your reply.I will make sure that patches on master have actually landed on 2.2 before reopen a issue.
Flags: needinfo?(zikui.yang)
Comment on attachment 8547217 [details] [review]
[PullReq] anefzaoui:bug-1115109 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): ?
[User impact] if declined: incorrect text alignment in Calendar for RTL users
[Testing completed]: manual, latest Gecko & Gaia
[Risk to taking this patch] (and alternatives if risky): none — this is just a trivial CSS update
[String changes made]: none
Flags: needinfo?(fabien)
Attachment #8547217 - Flags: approval-gaia-v2.2?(doliver)
Attachment #8547217 - Flags: approval-gaia-v2.2?(doliver) → approval-gaia-v2.2+
Priority: -- → P3

Updated

4 years ago
Flags: in-moztrap-
Duplicate of this bug: 1130967
landed on v2.2: https://github.com/mozilla-b2g/gaia/commit/b30c8e4303595a0fcb5b640d673cf8503b954701
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
status-b2g-v2.2: affected → fixed
status-b2g-master: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S4 (23jan)

Comment 18

4 years ago
Created attachment 8563174 [details]
2015-02-12-09-47-54.png

This issue has been verified successfully on Flame v2.2
STR:
1. Open Calendar app
2. Add an event
3. Observe the blue arrow where user can change the time of the event
**no overlap occurs
See attachment:2015-02-12-09-47-54.png
Rate:0/5

Flame 2.2 build:
Build ID               20150211002505
Gaia Revision          943be6fd146017dcd9d4c9d1027be1e43bad13eb
Gaia Date              2015-02-11 08:01:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e614443583e7
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150211.040242
Firmware Date          Wed Feb 11 04:02:53 EST 2015
Bootloader             L1TC000118D0

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
status-b2g-v2.2: fixed → verified

Comment 19

4 years ago
This issue has been verified successfully on Flame v3.0
STR:
1. Open Calendar app
2. Add an event
3. Observe the blue arrow where user can change the time of the event
**no overlap occurs
Rate:0/5

Flame 3.0 build:
Build ID               20150211010216
Gaia Revision          8c7865486a1b11076b849bbf8f7fccbaffbfafe7
Gaia Date              2015-02-10 17:34:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ee093ca70666
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150211.043725
Firmware Date          Wed Feb 11 04:37:36 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-master: fixed → verified
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15876/
Flags: in-moztrap- → in-moztrap+
You need to log in before you can comment on or make changes to this bug.