[RTL][Calendar]The text of Date and Time is not right-aligned when we creat a new event.

VERIFIED DUPLICATE of bug 1115109

Status

defect
P2
normal
VERIFIED DUPLICATE of bug 1115109
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: mmedeiros)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

Reporter

Description

4 years ago
[1.Description]:
[RTL][Calendar]When you creat a new event, the text in pull-down menu of Date and Time is not right-aligned.
See attachment:2015-02-09-17-59-16.png

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic.
1. Launch Calendar app.
2. Tap "+" to creat a new event.
3. Observe the text in pull-down menu of Date and Time.

[3.Expected Result]: 
3. The text in Date and Time menu should be right-aligned.

[4.Actual Result]: 
3. The text in Date and Time menu is left-aligned.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150208002500
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150208.035623
Firmware Date          Sun Feb  8 03:56:34 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Updated

4 years ago
QA Whiteboard: [rtl-impact]
feature-b2g: --- → 2.2+
Priority: -- → P2
Assignee: nobody → mmedeiros
this is in fact the same issue as Bug 1115109, the patch landed on master but still need to uplift to 2.2
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1115109
Reporter

Comment 2

4 years ago
Posted image verify_pass.png
This issue has been verified as "Pass" on latest build of Flame 2.2/3.0 and Nexus5 2.2/3.0 by STR in comment 0.
Result: The text in Date and Time menu is right-aligned.
See attachment: verify_pass.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150616002505
Gaia Revision          e7a0c6d5f4df04d45fb3f726efb9e8223600cb79
Gaia Date              2015-06-15 06:12:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8045028bf400
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150616.035412
Firmware Date          Tue Jun 16 03:54:24 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (pass)
Build ID               20150616010205
Gaia Revision          62ba52866f4e5ca9120dad5bfe62fc5df981dc39
Gaia Date              2015-06-15 19:09:24
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ce863f9d8864
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150616.060924
Firmware Date          Tue Jun 16 06:09:36 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (pass)
Build ID               20150616002505
Gaia Revision          e7a0c6d5f4df04d45fb3f726efb9e8223600cb79
Gaia Date              2015-06-15 06:12:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8045028bf400
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150616.034849
Firmware Date          Tue Jun 16 03:49:07 EDT 2015
Bootloader             HHZ12d

Device: Nexus 5 3.0 (pass)
Build ID               20150616160206
Gaia Revision          9d42e94446f2dc01b519172b6d75d81d4d435bdc
Gaia Date              2015-06-16 16:16:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/27caa5299f9f
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150616.193221
Firmware Date          Tue Jun 16 19:32:40 EDT 2015
Bootloader             HHZ12f
Reporter

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.