All users were logged out of Bugzilla on October 13th, 2018

[Flame][Calendar]The event notification can't disapper after you tap it to enter event details page.

RESOLVED DUPLICATE of bug 1113891

Status

--
major
RESOLVED DUPLICATE of bug 1113891
4 years ago
4 years ago

People

(Reporter: liuke, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8541174 [details]
logcat_1615.txt

[1.Description]:
[Flame][v2.2][Calendar]The event notification can't disapper from Notification after you tap it to enter event details page.
Found time:16:15
See attachment:1615.mp4 and logcat_1615.txt

[2.Testing Steps]: 
1.Launch Calendar.
2.Create an event, but set the start time to be an earlier time..
3.Tap "Save",  back to Month view.
4.Tap the event nofitication from Notification.
**Device will enter event details page.
5.Drag down the Notification.

Note:If you have more than 2 event nofitications in Notification, long tap Home key to kill calendar progress, then tap the event notification, device only displays calendar month view, it can't enter event details page.

[3.Expected Result]: 
5.The event notification should disapper from Notification.

[4.Actual Result]: 
5.The event notification can't disapper.

[5.Reproduction build]: 
Gaia-Rev        c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/0532f2509f3f
Build-ID        20141223010202
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: 3802
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → affected
(Reporter)

Comment 1

4 years ago
Created attachment 8541193 [details]
1615.MP4
blocking-b2g: --- → 2.2?
status-b2g-v2.1: --- → unaffected
Keywords: regression
Hi Gareth, Could you take a look at this, thanks.
Flags: needinfo?(gaye)

Comment 3

4 years ago
Created attachment 8543267 [details] [review]
Gaia PR
Attachment #8543267 - Flags: review?(gaye)
So this correctly handles the case where calendar is open and a notification is clicked. We still need to catch the case where calendar is closed. Will land this anyway though. Thanks for the contribution!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1113891
Comment on attachment 8543267 [details] [review]
Gaia PR

landed on master along with other, related work yesterday. thanks!!
Flags: needinfo?(gaye)
Attachment #8543267 - Flags: review?(gaye) → review+
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.