[Calendar] The event remains on the notification screen after tapping on it

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: psiphantong, Assigned: gaye)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-exploratory-2], )

Attachments

(3 attachments)

Reporter

Description

5 years ago
Posted file logcat.txt
Description:
When the user receives an event notification and taps on it, the event remains on the notification screen.

Repro Steps:
1) Update a Flame to 20141219040202
2) Go to Calendar, sign in with email account
3) Create event with a remind me for like 15 minutes before or less
4) When receiving the notification, tap on it  


Actual:
event remains on the notification screen

Expected:
event disappears from the notification screen


Flame 2.2

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141219040202
Gaia: deb90229734e5397cda806fb11f2e001fba83399
Gecko: 021b09e92d30
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Repro frequency:100%,
See attached:logcat,video clip: https://www.youtube.com/watch?v=VodQHhUZtew
Reporter

Comment 1

5 years ago
This issue does not occur on the Flame 2.1, the event disappears from the notification screen

Flame 2.1

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141219001200
Gaia: 6af3d029bae3a14f400fec0926f0f8ad7b579b4b
Gecko: d41f6bd64343
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
probably introduced by Bug 1042939
Depends on: 1042939
[Blocking Requested - why for this release]:

This can crowd up the users notification tray, making it hard to see what they have already checked. Also this is a regression. Nominating to block 2.2
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Assignee: nobody → gaye
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20141022130119
Gaia: 4d7f051cede6544f4c83580253c743c22b0cb279
Gecko: 6066a2a0766f
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141022131915
Gaia: 27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko: a4a78522b8d8
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: 4d7f051cede6544f4c83580253c743c22b0cb279
Gecko: a4a78522b8d8
Broken Gaia / Working Gecko = Repro
Gaia: 27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko: 6066a2a0766f
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/4d7f051cede6544f4c83580253c743c22b0cb279...27a1d1baaa8e375b70e043efee67d5f2206c330b


B2G Inbound
Last working
BuildID: 20141021154230
Gaia: 3d7d59248d672e28ef95b2bcc7e8bcf9d9af2de4
Gecko: c4b63beb3d76
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141021161729
Gaia: 3c901411771b4854c07c300ebcded0a793c625ed
Gecko: 1697bc226f4d
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: 3d7d59248d672e28ef95b2bcc7e8bcf9d9af2de4
Gecko: 1697bc226f4d
Broken Gaia / Working Gecko = Repro
Gaia: 3c901411771b4854c07c300ebcded0a793c625ed
Gecko: c4b63beb3d76
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/3d7d59248d672e28ef95b2bcc7e8bcf9d9af2de4...3c901411771b4854c07c300ebcded0a793c625ed
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Hi Gareth - The pushlog indicates the patch for Bug 1042939

can't put this in the Blocks section as it is in the 'depends on' section
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(gaye)
QA Contact: ckreinbring
Duplicate of this bug: 1115321
code changes LGTM (looking cleaner than before) and basic tests on the device confirmed that it is working as expected (when app is open or closed).
Flags: needinfo?(gaye)
Attachment #8544833 - Flags: review+
landed on master: https://github.com/mozilla-b2g/gaia/commit/bf64bc2528eb5ece8cd5b12af0e15ddca581ee0f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
blocking-b2g: 2.2? → 2.2+

Comment 9

4 years ago
This issue verified successfully on Flame 2.2
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
Build-ID        20150113162504
Version         37.0a2
Reproduce rate 0/5

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.