If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

%TypedArray% methods shouldn't be transparent for proxies

RESOLVED DUPLICATE of bug 1111243

Status

()

Core
JavaScript: Standard Library
RESOLVED DUPLICATE of bug 1111243
3 years ago
3 years ago

People

(Reporter: ziyunfei, Assigned: evilpie)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
js> Int8Array.prototype.includes.call(new Proxy(new Int8Array([1,2,3]), {}), 1)
true // This should throw a TypeError.
(Assignee)

Updated

3 years ago
Assignee: nobody → evilpies
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1111243
You need to log in before you can comment on or make changes to this bug.