Closed Bug 1115372 Opened 5 years ago Closed 5 years ago

Sending email to wrong addresses

Categories

(Thunderbird :: Address Book, defect)

31 Branch
x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1107844

People

(Reporter: bgufford, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

While forwarding email in BCC, I select the personal email address of a recipient that has a business email address in contacts.  Both addresses pop up but I carefully select the PERSONAL address.  TB will automatically select the business email address when forwarding mail or writing a new email.  I was very careful and deliberate when selecting the correct email address of a recipient.  


Actual results:

TB is selecting the recipients business email account as default even though I carefully selected the personal email account. 

This has occurred since the last update of 31.3.0 in December of 2014.  


Expected results:

Forwarded email should have gone to the individuals personal email account.

Instead it went to the recipients business account and he was flagged for receiving email that was not of a business nature.
Are you talking about problem of Bug 1107844?
I am helping this bug confirmation as volunteer, and can not reproduce the issue below configuration.

<System>
Windows 8.1 x64, HP EliteBook Revolve 810
Thunder Bird 31.3.0 for Windows (English US)

<Setup>
1. Create a contact in TB Address book; Name Charlie Brown, Office address whixxx@gmail.com, Personal address nicxxx@naver.com.
2. Send an email to myself to get one before testing.
3. Forward that email message to Charlie by his personal email; nicxxx@naver.com in BCC field instead of To.
4. Verify the inbox in both whixxx@gmail.com and nicxxx#naver.com.

Expect: find the message in only nicxxx@naver.com

Actual: Verified the message delivered to nicxxx@naver.com
Verified the contents in the message below.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~

BCC: Charlie Brown <nicxxx@naver.com>
Message-ID: <549C79F6.7080204@gmx.com>
Date: Thu, 25 Dec 2014 12:56:22 -0800
From: Jason Lee <nicxxx@gmx.com>
User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Thunderbird/31.3.0
MIME-Version: 1.0
Subject: Fwd: testing before forwarding
References: <549C775F.60407@gmx.com>
In-Reply-To: <549C775F.60407@gmx.com>
X-Forwarded-Message-Id: <549C775F.60407@gmx.com>
Content-Type: multipart/alternative;
 boundary="------------070205000306090402080503"

This is a multi-part message in MIME format.
--------------070205000306090402080503
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 7bit


This is sending to Charlie's personal email nicxxx@naver.com, not to 
whixxx@gmail.com.

-------- Forwarded Message --------
Subject: 	testing before forwarding
Date: 	Thu, 25 Dec 2014 12:45:19 -0800
From: 	Jason Lee <nicxxx@gmx.com>
To: 	nicxxx@gmx.com



need one from someone else....

<Suggestion>
if this is something different, please post your contact info's detail (all fields)
(In reply to WADA from comment #1)
> Are you talking about problem of Bug 1107844

WADA, YES this is exactly what is going on.  You nailed it and thank you for pointing us to 1107844.  You are on top of your game..
(In reply to WADA from comment #1)
> Are you talking about problem of Bug 1107844

WADA, YES this is exactly what is going on.  You nailed it and thank you for pointing us to 1107844.  You are on top of your game.

.(In reply to ju-hyoung.lee from comment #2)
> I am helping this bug confirmation as volunteer, and can not reproduce the
> issue below configuration.

Hi, Ju-hyoung lee you should know that this is the same bug as 1107844.  I really appreciate your input but WADA nailed it.  This bug will compromise security.  
Bill
> 
> <System>
> Windows 8.1 x64, HP EliteBook Revolve 810
> Thunder Bird 31.3.0 for Windows (English US)
> 
> <Setup>
> 1. Create a contact in TB Address book; Name Charlie Brown, Office address
> whixxx@gmail.com, Personal address nicxxx@naver.com.
> 2. Send an email to myself to get one before testing.
> 3. Forward that email message to Charlie by his personal email;
> nicxxx@naver.com in BCC field instead of To.
> 4. Verify the inbox in both whixxx@gmail.com and nicxxx#naver.com.
> 
> Expect: find the message in only nicxxx@naver.com
> 
> Actual: Verified the message delivered to nicxxx@naver.com
> Verified the contents in the message below.
> 
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> 
> BCC: Charlie Brown <nicxxx@naver.com>
> Message-ID: <549C79F6.7080204@gmx.com>
> Date: Thu, 25 Dec 2014 12:56:22 -0800
> From: Jason Lee <nicxxx@gmx.com>
> User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101
> Thunderbird/31.3.0
> MIME-Version: 1.0
> Subject: Fwd: testing before forwarding
> References: <549C775F.60407@gmx.com>
> In-Reply-To: <549C775F.60407@gmx.com>
> X-Forwarded-Message-Id: <549C775F.60407@gmx.com>
> Content-Type: multipart/alternative;
>  boundary="------------070205000306090402080503"
> 
> This is a multi-part message in MIME format.
> --------------070205000306090402080503
> Content-Type: text/plain; charset=utf-8; format=flowed
> Content-Transfer-Encoding: 7bit
> 
> 
> This is sending to Charlie's personal email nicxxx@naver.com, not to 
> whixxx@gmail.com.
> 
> -------- Forwarded Message --------
> Subject: 	testing before forwarding
> Date: 	Thu, 25 Dec 2014 12:45:19 -0800
> From: 	Jason Lee <nicxxx@gmx.com>
> To: 	nicxxx@gmx.com
> 
> 
> 
> need one from someone else....
> 
> <Suggestion>
> if this is something different, please post your contact info's detail (all
> fields)
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1107844
Thanks, I am glad to see more characterization/isolation data in 1107844. I continue helping you.
You need to log in before you can comment on or make changes to this bug.