Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1115418
3 years ago
3 years ago

People

(Reporter: bugzilla77, Unassigned)

Tracking

34 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8541313 [details]
hotspot.html

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36

Steps to reproduce:

http://bugs.idsl.pl/firefox/hotspot.html

Green block is associated with hotspot_bitmap.cur cursor (containing BITMAP format data).
Red block is associated with hotspot_png.cur cursor (containing PNG format data).
Both cursors look identical.
Both cursors contain binary defined hotspot 31px 31px (file char positions: 10, 12).


Actual results:

hotspot_png.cur hotspot is ignored!


Expected results:

hotspots respected
(Reporter)

Comment 1

3 years ago
Created attachment 8541314 [details]
hotspot_bitmap.cur
(Reporter)

Comment 2

3 years ago
Created attachment 8541315 [details]
hotspot_png.cur
(Reporter)

Comment 3

3 years ago
Comment on attachment 8541313 [details]
hotspot.html

<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
 <body style="cursor:default">
  <div style="padding-bottom:1em">Gecko cursor hotspot BUG</div>
  <div style="display:table">
   <div style="display:table-cell;background:green;cursor:url(/attachment.cgi?id=8541314),auto;padding:100px 250px">1. MOUSEOVER this box<br/>2. MOVE cursor to RED box.</div>
   <div style="display:table-cell;background:red;cursor:url(/attachment.cgi?id=8541315),auto;padding:100px 50px">3. Have you seen a JUMP on box edge on Firefox 34?<br/>4. This is fluently on others browsers.</div>
  </div>
  <div style="padding-top:1em">Green block is associated with hotspot_bitmap.cur cursor (containing BITMAP format data).</div>
  <div>Red block is associated with hotspot_png.cur cursor (containing PNG format data).</div>
  <div>Both cursors look identical.</div>
  <div style="padding-bottom:1em">Both cursors contain binary defined hotspot 31px 31px (file char positions: 10, 12).</div>
  <div style="color:red">Firefox 34: cursor jumps on box edge (hotspot_png.cur hotspot is ignored!)</div>
  <div style="color:green">Chrome 39 / Opera 26: no jumps (hotspots respected)</div>
  <div style="color:green">Internet Explorer 11: no jumps (hotspots respected)</div>
 </body>
</html>
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1115418
You need to log in before you can comment on or make changes to this bug.