Status

mozilla.org
Licensing
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Axel Nennker, Assigned: gerv)

Tracking

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141127111021

Steps to reproduce:

I want to use libusb
http://www.libusb.org/


Actual results:

libusb is under LGPL 2.1 or newer
http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html


Expected results:

Other Mozillians (Andreas Gal) started to implement WebUSB
https://wiki.mozilla.org/WebAPI/WebUSB
and to my knowledge use libusb too.
https://bugzilla.mozilla.org/show_bug.cgi?id=webusb

Is it OK to use libusb in mozilla-central?
(Assignee)

Comment 1

3 years ago
As I said in that other bug:

"LGPL works for us as long as the code is in a discrete dynamically-linked library. If you want to do something other than that, at the very least it would require more analysis."

Is that enough information? If not, I'll need more details of how you plan to use the code in conjunction with the existing code (i.e. linking details).

Gerv
(Assignee)

Comment 2

3 years ago
Resolving fixed due to lack of input from reporter.

Gerv
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.