Closed Bug 1115731 Opened 5 years ago Closed 5 years ago

OOM crash on the Galaxy Nexus on loading heavy image content

Categories

(Firefox for Android :: General, defect)

34 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 739159

People

(Reporter: bugs.m1, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [OOM])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141127111021

Steps to reproduce:

Visited https://forum.freifunk.net/t/tp-link-cpe210-510/594


Actual results:

Firefox crashes and goes back to the phones home screen. 


Expected results:

No crash.
Similar bug see https://bugzilla.mozilla.org/show_bug.cgi?id=723087
OS: Linux → Android
Hardware: x86_64 → ARM
D/GeckoMemoryMonitor(18480): onLowMemory() notification received

Android killed the browser because your device has ran out of memory.
Whiteboard: [OOM]
Martin, with which phone are you seeing this?
I can't reproduce, using Galaxy Nexus, using current trunk build.

But I have to say, I quite often encounter it, when the browser is closed, because of oom.

Is there some tracking bug perhaps, that is tracking these kinds of oom issues?
It's a Galaxy Nexus device. 

Shouldn't Android kill other tasks instead of the running one when OOM situation occurs?
(In reply to martin from comment #3)
> It's a Galaxy Nexus device. 
> 
> Shouldn't Android kill other tasks instead of the running one when OOM
> situation occurs?

It did. Look at your log and search for 'has died.'
So I can't visit this URL because it has to bulky pictures in it and my device runs out of memory? The firefox process swells up to 210 MB in size. 693 MB of main memory is reported on this device (wikipedia says 1 GB?). 

Shouldn't Android be capable of handling such situations?
It's Firefox that should be capable of handling such situations, by not using that much memory.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: crash when visiting specific url → OOM crash on the Galaxy Nexus on loading heavy image content
(In reply to martin from comment #5)
> 693 MB of main memory is reported on this device (wikipedia says 1 GB?).

I imagine this is because some memory is reserved for the system.

> Shouldn't Android be capable of handling such situations?

I'm not sure if this is possible because the foreground application should take priority, but Firefox may be closed before some "essential" background services (e.g. maybe Google Play Services?).

If it isn't possible, I imagine Firefox has actually just requested to use more than 693 MB of memory. Android's way of dealing with this is killing Firefox.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 739159
You need to log in before you can comment on or make changes to this bug.