Closed Bug 1115924 Opened 5 years ago Closed 5 years ago

InContent prefs - Eliminate double borders from buttons and links in high contrast mode

Categories

(Firefox :: Theme, defect)

All
Windows 10
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 38
Tracking Status
firefox38 --- fixed

People

(Reporter: ntim, Assigned: Paenglab)

References

Details

(Whiteboard: [testday-20150901])

Attachments

(2 files)

The second border is basically a transparent border that turns into a dotted one when focused. Unfortunatly, transparent turns into a visible color in HC mode.

Here's the quickest fix I could find :
menulist:not(:-moz-focusring) > hbox,
button:not(.help-button):not(:-moz-focusring) > hbox,
.text-link:not(:-moz-focusring) {
  border-style: none;
}
De-listing from the hard-blocker tracking since this is a polish-related bug in high-contrast mode, which is not frequently used.
Blocks: 718011
No longer blocks: ship-incontent-prefs
Simply add selectors to the already existing rules.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8557631 - Flags: review?(jaws)
Comment on attachment 8557631 [details] [diff] [review]
NoFocusringBorder.patch

I'm not sure this is a Windows only issue. Page Colors settings are also on OSX and Linux right ? And Linux also has HC themes too.
(In reply to Tim Nguyen [:ntim] from comment #3)
> Comment on attachment 8557631 [details] [diff] [review]
> NoFocusringBorder.patch
> 
> I'm not sure this is a Windows only issue. Page Colors settings are also on
> OSX and Linux right ? And Linux also has HC themes too.

Oh, I see there were existing rules already. Nevermind.
It's a Windows only issue. Checked with page colors disabled on Linux and OS X.
Comment on attachment 8557631 [details] [diff] [review]
NoFocusringBorder.patch

I can't reproduce this bug using Firefox Nightly 38.0a1 (2015-02-11) on Windows 8.1 with the High Contrast White theme enabled and tabbing through the buttons as well as the clicking on the buttons.
Flags: needinfo?(richard.marti)
Attachment #8557631 - Flags: review?(jaws)
Attached image borders.png
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #6)
> Comment on attachment 8557631 [details] [diff] [review]
> NoFocusringBorder.patch
> 
> I can't reproduce this bug using Firefox Nightly 38.0a1 (2015-02-11) on
> Windows 8.1 with the High Contrast White theme enabled and tabbing through
> the buttons as well as the clicking on the buttons.

The screenshot is from Win 7 but I see this also under Win 8. The focus ring is good visible around the "Learn more" links and also the second border inside the menulists. The button's focusring is almost not visible because it looks like a normal 2px border but it's the 1px border plus the 1px focusring.
Flags: needinfo?(richard.marti) → needinfo?(jaws)
Comment on attachment 8557631 [details] [diff] [review]
NoFocusringBorder.patch

Review of attachment 8557631 [details] [diff] [review]:
-----------------------------------------------------------------

Ok, I can see the change now. Thanks!
Attachment #8557631 - Flags: review+
Flags: needinfo?(jaws)
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/5bf16b55dd0d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 38
This is verified fixed in a QA test day.
Status: RESOLVED → VERIFIED
Whiteboard: [testday-20150901]
You need to log in before you can comment on or make changes to this bug.