[Flame][Lockscreen]After reboot, the clock on LockScreen won't update

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: gweng, Assigned: gweng)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master verified)

Details

Attachments

(1 attachment, 3 obsolete attachments)

As Bug 1115652 Comment 13, I create this bug to handle the issue individually.
(Assignee)

Updated

4 years ago
Assignee: nobody → gweng
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
(Assignee)

Comment 1

4 years ago
Created attachment 8542093 [details] [review]
Patch

1. Remove the duplicated clock.js in LockScreen
2. Move the code to setInterval to lockscreen.js
3. Add tests.

What I'm not sure is the original code looks complicated and I don't know why, so the potential risk exists. However, if the code is majorly for statusbar, maybe for LockScreen the code in my patch is enough.
Attachment #8542093 - Flags: review?(timdream)
Attachment #8542093 - Flags: review?(timdream) → review+
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

4 years ago
I just confirmed on v2.1 we have this issue, too. So I set the tracking flag.
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
(Assignee)

Comment 5

4 years ago
Sorry I just too hurry to land the patch. It need an additional fix for the time issue.
(Assignee)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

4 years ago
status-b2g-v2.2: fixed → affected
(Assignee)

Comment 6

4 years ago
OK I've updated the patch. Would re-land it after test.
(Assignee)

Comment 9

4 years ago
Created attachment 8542466 [details] [review]
Patch v2.1

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Broken since v2.0 (I suspect it was broken even before v2.0)
[User impact] if declined: Bug no fix
[Testing completed]:With some intermittent errors, re-running: https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=d685b9fde921
[Risk to taking this patch] (and alternatives if risky): No
[String changes made]: No
Attachment #8542466 - Flags: approval-gaia-v2.1?(bbajaj)
(Assignee)

Comment 10

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/12d74b902d356f94837bcf0edcd4f4089f77207d
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
status-b2g-v2.2: affected → fixed
(Assignee)

Updated

4 years ago
Depends on: 1119097
The patch for this bug is causing bug 1117981. I've tried to reproduce this bug (comment 0), and found out that the clock on lockscreen DOES update, it just won't update until the screen is turned off and on either by screen timeout or manually.

Observed behavior: After reboot (with a SIM inserted but NOT connected to internet), I'm seeing this bug 1061797 where the time and date is completely wrong, and this incorrect time won't update at all until screen is turned off and on again.

This bug is perhaps another iteration of bug 1061797, or could be a separate bug.

Also, 2.0 is affected - time on lockscreen only starts to update (to the correct time) after screen off/on after reboot.
status-b2g-v2.0: --- → affected
Flags: needinfo?(ktucker)
Given this is not a new regression in 2.1 plus keeping in mind the fallouts of this landing, lets not uplift this to 2.1 and this bug can get addressed in 2.2. Please Ni me if I am missing to consider any other data point for uplifting this to 2.1
Keywords: qawanted

Updated

4 years ago
Attachment #8542466 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1-
I'm removing the keyword qawanted since I don't see a request here. Please re-add it if i am incorrect.
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: qawanted
(Assignee)

Comment 14

4 years ago
Let's make smoketest of Bug 1117981 happy again: 

Revert "Merge pull request #27052 from snowmantw/bug1116091-rev2" 
https://github.com/mozilla-b2g/gaia/commit/753e6b06b2d234129c3563d97050d3b59ac01d30
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 15

4 years ago
Comment on attachment 8542466 [details] [review]
Patch v2.1

Let's reset the patching status.
Attachment #8542466 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Attachment #8542465 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Attachment #8542093 - Attachment is obsolete: true
(Assignee)

Comment 16

4 years ago
This long video shows my new WIP patch can fix this bug without result in regression like Bug 1117981, since I walked through the whole flow Bug 1117981 described, and there is no such bug.

https://www.youtube.com/watch?v=5bCQIGUBCp0

One thing interesting is both Statusbar and LockScreen would have 'two minutes' leaping issue. So what I do is make sure LockScreen works as Statusbar, which people like to compare it with LockScreen.

I'm now investigating the 'two minutes' leaping issue, and make sure this is fixable.
(Assignee)

Comment 17

4 years ago
Yes. With the current Gaia master, Statusbar has the two minutes leaping issue, too. So at least my patch strictly fixed the issue described here, but for that issue this bug doesn't cover that. I'll submit the patch with test.
(Assignee)

Comment 18

4 years ago
The 'two minutes' leaping on master is: after unlock the statusbar would not update clock until the second minutes passed. For example:

-- unlock --
10:23 on statusbar
(now it is 10:24)
10:23 on statusbar (incorrect)
(now it is 10:25)
10:25 on statusbar (here we have the 'two minutes leaping')
(now it is 10:26)
10:26 on statusbar (the issue had gone)

With my patch on LockScreen it has the same issue, too. To simplify the work I don't think to fix it in this bug is a good idea, I may fire another bug for it. This bug would only fix the async clock between Statusbar & LockScreen. Namely, if the patch can make LockScreen's clock works as Statusbar after rebooting, then it complete its job.
(Assignee)

Comment 19

4 years ago
And both the two minutes leaping would disappear after it first occurs. So I'm sure that's not a LockScreen only issue.
(Assignee)

Updated

4 years ago
status-b2g-v2.2: fixed → affected
(Assignee)

Comment 20

4 years ago
Created attachment 8546521 [details] [review]
Patch

Fixed in the old way. I'm sure there is no errors in Bug 1117981 (see the video). For 2.1 I would submit another similar patch later.
Attachment #8546521 - Flags: review?(timdream)
Attachment #8546521 - Flags: review?(timdream) → review+
(Assignee)

Comment 21

4 years ago
Since a bit of old I rebased the patch, and wait the Try result.
(Assignee)

Comment 22

4 years ago
(Sorry for the typo)
(Assignee)

Comment 24

4 years ago
On the real device it fixed the bug and no regression like the old one. So I'll land this patch.
(Assignee)

Comment 25

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/6a3dcce45af7a3a7a04487a964ffe94e075ad9eb

I'll wait several days to make sure there is no regression like the old one, and than submit and land patches for other branches. Keep NI to remind myself.
Flags: needinfo?(gweng)
(Assignee)

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
status-b2g-master: --- → fixed
Flags: needinfo?(gweng)
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Flags: needinfo?(gweng)
This issue is verified fixed on Flame 2.2 and Master.

Result: The clock on the lockscreen updates after rebooting.
 
Device: Flame Master (319mb, full flash)
Build ID: 20150129010239
Gaia: 9d2378a9ef092ab1fc15c3a9f7fc4171aab59d57
Gecko: 6bfc0e1c4b29
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Comment 27

3 years ago
Clear forgotten NI.
Flags: needinfo?(gweng)
You need to log in before you can comment on or make changes to this bug.