Commit access level 1 for Liz Henry

RESOLVED FIXED

Status

mozilla.org
Repository Account Requests
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: lizzard, Assigned: ashlee)

Tracking

Details

Attachments

(1 attachment)

Hi, I'd like to have access to the try server, as lhenry@mozilla.com, for updating some mochitests. Thanks!
Liz: Have you filled out the Commit access form and returned it? You will also need a voucher to post in the bug.

https://www.mozilla.org/en-US/about/governance/policies/commit/notification/ has the form link and details.
Flags: needinfo?(lhenry)
(Reporter)

Comment 2

3 years ago
Created attachment 8542261 [details]
public ssh key
Flags: needinfo?(lhenry)
(Reporter)

Comment 3

3 years ago
Emailed signed agreement to marcia@mozilla.com.
(Reporter)

Comment 4

3 years ago
Hi Joel, would you vouch for me for level 1 access? Thanks!
Flags: needinfo?(jmaher)
I vouch for Liz to gain commit level 1 access.  She is a trusted Mozillian for many years!
Flags: needinfo?(jmaher)

Comment 6

3 years ago
Waiting on confirmation of the form.
Flags: needinfo?(mozillamarcia.knous)
form received. Waiting on decision from IT as to where these requests moved now that server-ops is no longer functioning.
Flags: needinfo?(mozillamarcia.knous)
Moving over to achavez for account creation.
Assignee: mozillamarcia.knous → achavez
(Assignee)

Comment 9

3 years ago
+SSH key, +HG, +level_1.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

3 years ago
I still can't connect to the try server, though.  If I do ssh -v lhenry@people.mozilla.org, I can't log in. If I ssh -v as ehenry, then it works fine.   I tried changing my .hgrc username to ehenry@mozilla.com, but that didn't help.   Did you maybe make my account lhenry in one place, and ehenry in another? I'm not sure how to troubleshoot this further....
Your username in .hgrc is used for changesets in mercurial, not authentication for ssh, so it's irrelevant here (you can set it to whatever you want, lhenry@ or even your personal email address).  The reason people.m.o works and hg.m.o doesn't is likely just that people is more lenient.  What happens if you | ssh ehenry@mozilla.com@hg.mozilla.org |?  people.m.o. accepts just first names and assumes they're @mozilla.com, while hg.m.o wants fully qualified usernames. (probably because one is only accessible to employees and one is public).

Assuming that works, you should put this all in your ~/.ssh/config so you don't have to think about it any more.
Flags: needinfo?(lhenry)
(Reporter)

Comment 12

3 years ago
Kyle, thanks!  It was that I had pointy brackets around my email address in the .ssh/config file. Whoops!
Flags: needinfo?(lhenry)
Duplicate of this bug: 1135162
See Also: → bug 1241511
You need to log in before you can comment on or make changes to this bug.