profile manager: While deleting one profile, all other profiles were deleted as well.

RESOLVED DUPLICATE of bug 302087

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 302087
3 years ago
2 years ago

People

(Reporter: KitchM, Unassigned)

Tracking

30 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141127110656

Steps to reproduce:

I selected a profile from the list of profiles in the profile manager at program start.  I selected "Delete Profile...".

It prompts the user with the message:
Deleting a profile will remove the profile from the list of available profiles and cannot be undone.
You may also choose to delete the profile data files, including your settings, certificates and other user-related data. This option will delete the folder "/home/xxx/.thunderbird/xxxxxxxx.default" and cannot be undone.
Would you like to delete the profile data files?

I selected to deleted the files.

But therein lies the problem.  The warning appears to imply that only that one particular profile will be removed.  So obviously one would like to remove its data files.

However, it removed all other profiles as well.  This can be doubly damning on Linux system where the data is very likely to be unrecoverable.


Actual results:

While deleting one profile, all other profiles were deleted as well.


Expected results:

The program should always notice if other profiles exist and not allow them to be deleted when the focus was on just one.

Reasonable safeguards should always be programmed into the application.

Comment 1

3 years ago
That's not how it's supposed to work, and it doesn't either for me (just tested on trunk).
Summary: Fatal and Misleading Deletion Warning - Big Data Loss Risk → profile manager: While deleting one profile, all other profiles were deleted as well.
(Reporter)

Comment 2

3 years ago
One thing I'm particularly sure about is that the program allowed a person to create a profile that existed in the root of the .thunderbird directory, rather than .thunderbird/xxxx.default profile directory.  Deletion of that may have caused all profiles in that directory to be deleted.

Obviously, the program should know the difference.  First, it should never allow a profile to be created without its own specific sub-directory.  Second, it should never, ever allow the deletion of anything that does not belong to that specific profile.  Thunderbird programming failed in this regard.

I believe that it is reasonable for people to be able to trust their software.

Thanks.

Comment 3

3 years ago
The profile manager does not allow creating a profile in .thunderbird. You can choose .thunderbird but the profile directory would be one directory beneath that, like .thunderbird/xcvadfadf.profile2
(Reporter)

Comment 4

3 years ago
However, that is exactly what happened.

Comment 5

2 years ago
(In reply to Magnus Melin from comment #3)
> The profile manager does not allow creating a profile in .thunderbird. You
> can choose .thunderbird but the profile directory would be one directory
> beneath that, like .thunderbird/xcvadfadf.profile2

(In reply to KitchM from comment #4)
> However, that is exactly what happened.

ISTR there was a time when this could happen but has since been fixed. *But*, can you still make it create a profile in an inappropriate location, such that the problem you report here can be reproduced?
Flags: needinfo?(tech)
(Reporter)

Comment 6

2 years ago
No.  This is also so old that the problem no longer has the same environment.  You wrote, "ISTR there was a time when this could happen but has since been fixed" but you didn't give a time frame.  If it was about the same time, then I would say that it is too bad it couldn't have been fixed at the time.  That's all I know.
Flags: needinfo?(tech)

Comment 7

2 years ago
Best guess is somehow the profile manager or the profile involved was pointing to the wrong place. Whatever the reason, it seems to me the two most relevant bugs are
Bug 302087 - Inadequate warning before Profile Manager deletes non-Mozilla files
Bug 270705 - Uninstalling profile deleted large amount of files not belonging to it 

Only bug 302087 is still open.  Perhaps not an exact match, but it seems like the best match available.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → General
Resolution: --- → DUPLICATE
Duplicate of bug: 302087
You need to log in before you can comment on or make changes to this bug.