context menu too big / nonnative for in-content prefs password manager

RESOLVED DUPLICATE of bug 1247214

Status

()

P4
normal
RESOLVED DUPLICATE of bug 1247214
4 years ago
3 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sf-hackweek])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8542307 [details]
Too big

See screenshot. The in-content prefs has a content menu that's way too big and non-native. It's ok in other places, so far I've only noticed it in the password manager.
(Reporter)

Comment 1

4 years ago
Created attachment 8542308 [details]
Normal
Reproducible on Windows too
OS: Mac OS X → All
Hardware: x86 → All
Blocks: 718011
Component: General → Preferences

Comment 3

4 years ago
I think this should block shipping, if only because there are a number of these size bugs which should be fixable in one fell swoop, and together they should block shipping. :-)
Blocks: 1014201
(In reply to Ian Moody (:Kwan) from comment #4)

Thanks for finding that. Would you be interested in putting together a patch to fix this?
Flags: needinfo?(moz-ian)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #5)
> (In reply to Ian Moody (:Kwan) from comment #4)
> 
> Thanks for finding that. Would you be interested in putting together a patch
> to fix this?

Yeah I'd be willing to do so.
Not sure what the best approach would be though.  There's no obvious :-moz-anonymous-content/:-moz-xbl-generated I can see on MDN that I could :not().
Flags: needinfo?(moz-ian)

Comment 7

4 years ago
(In reply to Ian Moody (:Kwan) from comment #6)
> (In reply to Jared Wein [:jaws] (please needinfo? me) from comment #5)
> > (In reply to Ian Moody (:Kwan) from comment #4)
> > 
> > Thanks for finding that. Would you be interested in putting together a patch
> > to fix this?
> 
> Yeah I'd be willing to do so.
> Not sure what the best approach would be though.  There's no obvious
> :-moz-anonymous-content/:-moz-xbl-generated I can see on MDN that I could
> :not().

Does switching these rules to rem instead of em work? (Might not, but worth a shot)
(In reply to :Gijs Kruitbosch from comment #7)
> (In reply to Ian Moody (:Kwan) from comment #6)
> > (In reply to Jared Wein [:jaws] (please needinfo? me) from comment #5)
> > > (In reply to Ian Moody (:Kwan) from comment #4)
> > > 
> > > Thanks for finding that. Would you be interested in putting together a patch
> > > to fix this?
> > 
> > Yeah I'd be willing to do so.
> > Not sure what the best approach would be though.  There's no obvious
> > :-moz-anonymous-content/:-moz-xbl-generated I can see on MDN that I could
> > :not().
> 
> Does switching these rules to rem instead of em work? (Might not, but worth
> a shot)

It does not.
De-listing from the hard-blocker list as this is a pretty small corner case and doesn't prohibit usage.
No longer blocks: 1014201

Updated

4 years ago
Whiteboard: [sf-hackweek]
Duplicate of this bug: 1211924
This should have been fixed by bug 1247214. Katie, can you confirm?
Flags: needinfo?(kbroida)
Confirmed! We resolved this font issue in bug 1247214 by preventing the context menu from inheriting the dialog box's styling.
Flags: needinfo?(kbroida)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1247214
You need to log in before you can comment on or make changes to this bug.