Support "sequence" append mode

RESOLVED DUPLICATE of bug 1119208

Status

()

P5
normal
RESOLVED DUPLICATE of bug 1119208
4 years ago
4 years ago

People

(Reporter: bholley, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
See http://w3c.github.io/media-source/#idl-def-AppendMode

Right now we just assume "segments" have nothing in the way of support for sequence. I'm going to land a patch that makes us explicitly throw (rather than failing silently). But we'll eventually need to implement this.

Youtube's html5player.js does not appear to set SourceBuffer.prototype.mode, so youtube is probably unaffected.
(Reporter)

Comment 1

4 years ago
Er, I didn't mean to take this.
Assignee: bobbyholley → nobody
(Reporter)

Updated

4 years ago
Depends on: 1116355
Priority: -- → P5
New MSE fully support sequence mode (though webref do not properly test it)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1119208
You need to log in before you can comment on or make changes to this bug.