[FFOS2.0][Woodduck][File manager] Music will stop play it form file manager when MS sleep.

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
DEFECT DESCRIPTION:
 Music will stop.
 
  REPRODUCING PROCEDURES:
 Enter File manager -> Play a music -> Waiting the MS sleep
 
  EXPECTED BEHAVIOUR:
 Should be play.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:100%
 
 Number: 0752-2639306(61306)
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Dears,
 Can you tell my why added this function?
 
 apps/music/js/open.js
 
 // Terminate music playback when visibility is changed.
   window.addEventListener('visibilitychange',
     function onVisibilityChanged() {
       if (document.hidden) {
         done();
       }
     });

Comment 2

4 years ago
Hi Gary,
Is this by design? Thanks!
Flags: needinfo?(gchen)
Yes, this is by design.
We don't allow |webActivities| to block playback resource, so we terminate music playback when app is hidden.
Thank.
Flags: needinfo?(gchen)

Comment 4

4 years ago
Hi Reporter,
The current behavior is by Mozilla design.
You are welcome to customize if you like to change the behavior on your side. Thanks!
Blocks: 1054172, 1107999
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(sync-1)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.