Closed Bug 1116456 Opened 5 years ago Closed 5 years ago

[v2.2] Investigate test_marketplace_packaged_app.py failure

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: RobertC, Assigned: martijn.martijn)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
RobertC
: review+
jlorenzo
: review+
Details | Review
test_marketplace_packaged_app.py has failed in the last Jenkins run.

http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.ui.functional.smoke/226/HTML_Report/

I was able to reproduce the error locally and it looks like the installed app is not the expected one. The issue can also be reproduced manually since after we input the search term the app we are expecting is not returned at all.

Repro rate 5/5

expected title = Privileged App Test
the first app returned (the one we install) has the title mozLauncher Test
QA Whiteboard: [fxosqa-auto-backlog+]
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
There is now an "Show All apps/Apps for My Device" option. The default is set for "Apps for My Device", which makes it not find the app that we're looking for.
Assignee: nobody → martijn.martijn
Attached file marketplace_fix
This fixes it. I had to add a small time.sleep(0.5) call to get this test working on b2g desktop.

While trying to get this fixed, I had the typical troubles with the switching contexts, knowing in which context I was and webIDE not really helping (in this case, "Pick an element from the page" didn't work for the select dialog popup).
Attachment #8542549 - Flags: review?(robert.chira)
Comment on attachment 8542549 [details] [review]
marketplace_fix

Johan was already accidentally looking at this code, so adding him as a reviewer.
Attachment #8542549 - Flags: review?(jlorenzo)
Johan had a problem with timing out this test on:
Wait(self.marionette).until(
  expected.element_not_present(*self._search_results_loading_locator))
in __init__ of SearchResults.
Replacing it with this:
self.wait_for_element_not_present(*self._search_results_loading_locator)
fixed it for him, so I've now used that in the pull request.
This was originally reported as being manually reproducible but from the additional comments it looks like it is a test error?  For that reason I'm not going to report this as breaking Automation Smoke Tests, please let me know if this is correct.
That is correct.
The Marketplace site was updated with this "Show All apps/Apps for My Device" option. It has the "Apps for My Device" option set by default, which causes the "test-webapi-permissions" app not to be found, which is apparently not an "App for My Device".
Comment on attachment 8542549 [details] [review]
marketplace_fix

Comments in the PR
Attachment #8542549 - Flags: review?(robert.chira) → review-
I had to tweak def select in base.py a little bit to get it working for this marketplace packaged app test, because in there, the select popup is immediately closed after selecting something (I wonder how that is done).
Adhoc run: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/530/
Comment on attachment 8542549 [details] [review]
marketplace_fix

Jenkins adhoc run all green.
Attachment #8542549 - Flags: review- → review?(robert.chira)
Comment on attachment 8542549 [details] [review]
marketplace_fix

LGTM!
Attachment #8542549 - Flags: review?(jlorenzo) → review+
Comment on attachment 8542549 [details] [review]
marketplace_fix

Merged in master:
https://github.com/mozilla-b2g/gaia/commit/2ad8157515fbc1be956940325b28ef5090e43ce5
Attachment #8542549 - Flags: review?(robert.chira) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
QA Whiteboard: [fxosqa-auto-backlog+] → [fxosqa-auto-s7][fxosqa-auto-points=4]
Flags: in-qa-testsuite+
See Also: → 1130942
You need to log in before you can comment on or make changes to this bug.