Closed Bug 1116763 Opened 7 years ago Closed 7 years ago

test_AudioNodeDevtoolsAPI.html leaks MediaStreamGraph intermittently when run as a standalone directory

Categories

(Core :: Web Audio, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1117727

People

(Reporter: jmaher, Unassigned)

References

Details

+++ This bug was initially created as a clone of Bug #1116202 +++

in bug 1110982, we are looking to enable tests where we run a fresh browser instance per directory.  Usually what happens is that a few tests fail because they accidentally depend on the state of the browser from an earlier test.

in https://bugzilla.mozilla.org/show_bug.cgi?id=1116202#c12, we have asserted that one leak is fixed related to AudioNodeStreams, we have a try push with a patch from bug 1116202 on try and here is the remaining leaks:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=5e08d8164d81

This test causes a leak in mac 10.8 debug jobs. The failure goes like this:

12:14:42 WARNING - TEST-UNEXPECTED-FAIL | leakcheck | default process: 944 bytes leaked (AsyncLatencyLogger, CondVar, GraphDriver, MediaStreamGraph, MediaStreamGraphImpl, ...)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1117727
You need to log in before you can comment on or make changes to this bug.