Closed Bug 1117016 Opened 5 years ago Closed 5 years ago

[e10s] On print preview page "Landscape" option shows page as "Portrait"

Categories

(Core :: Print Preview, defect)

37 Branch
x86
Windows 7
defect
Not set
Points:
1

Tracking

()

RESOLVED FIXED
Tracking Status
e10s m6+ ---

People

(Reporter: mamo, Assigned: mconley, NeedInfo)

References

Details

Attachments

(1 file)

Attached image landscape_bug.JPG
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150101030214

Steps to reproduce:

1. opened Nightly,  version 37.0a1 (2015-01-01)
2. open any web page
3. from file menu pres print preview
4.click on "Landscape" 


Actual results:

"Landscape"  wont change page rendering , it stays unchanged 


Expected results:

"Landscape" option  will render page as "Landscape"
Iteration: --- → 37.1
Points: --- → 1
Priority: -- → P1
WFM, try with a fresh profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Iteration: 37.1 → ---
Component: Untriaged → Print Preview
Flags: needinfo?(mamo)
Priority: P1 → --
Product: Firefox → Core
I tried on nightly build 37.0a1 (2015-01-02)today with fresh profile.  Issue related with E10s. 
When E10S enabled issue we have issue, after disabling it works as designed.
Flags: needinfo?(mamo)
Blocks: e10s
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: On print preview page "Landscape" option shows page as "Portrait" → [e10s] On print preview page "Landscape" option shows page as "Portrait"
Blocks: 927188
Assignee: nobody → mconley
I am not able to reproduce this on a recent Nightly. Are you still seeing this, mamo?
Flags: needinfo?(mamo)
Working range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0189941a3fd5&tochange=43fb1f92e8d4

It has been fixed by your patches in bug 1088070, Mike.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Depends on: 1088070
You need to log in before you can comment on or make changes to this bug.