High CPU, slow system/bad performance. High activity in paint

NEW
Unassigned

Status

Thunderbird
General
--
major
3 years ago
5 months ago

People

(Reporter: wsmwk, Unassigned, NeedInfo)

Tracking

({perf})

Trunk
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
High CPU. Nothing happening/showing in status bar, nor in UI. By the time I noticed and started the profile capature it it may have started downloading a message. Lasted maybe 5 minutes?

I have accessibility.force_disabled = 1 from previous testing of bug 939462

http://people.mozilla.org/~bgirard/cleopatra/?1420241733183#report=f399558a8218a5cdf2a255c9172e1c1646efcc97
(Reporter)

Comment 1

3 years ago
most time is in mozilla::FrameLayerBuilder::DrawPaintedLayer(mozilla::layers::PaintedLayer *,gfxContext *,nsIntRegion const &,mozilla::layers::DrawRegionClip,nsIntRegion const &,void *)

This was on my d531 vista laptop
(Reporter)

Comment 2

3 years ago
I need to retest this semi-retired laptop
Flags: needinfo?(vseerror)
(Reporter)

Updated

3 years ago
See Also: → bug 1118278

Comment 3

5 months ago
Created attachment 8898434 [details]
Slow Thunderbird GUI with no activity showing, and low cpu usage.

Comment 4

5 months ago
(In reply to kobaz from comment #3)
> Created attachment 8898434 [details]
> Slow Thunderbird GUI with no activity showing, and low cpu usage.

Uploaded screencast to show clicking around with a VERY slow to respond thunderbird.  Basically as soon as I move the mouse, I'm clicking on the message.  And you'll notice how long it takes to load.
You need to log in before you can comment on or make changes to this bug.