Implement new first time experience

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: benfrancis, Assigned: daleharvey)

Tracking

unspecified
2.2 S6 (20feb)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

Reporter

Description

5 years ago
No description provided.
What is this about?
feature-b2g: --- → 2.2+
Assignee: nobody → dale
Target Milestone: --- → 2.2 S5 (6feb)
Is this for search app?
Whiteboard: [systemsfe]
Assignee

Comment 3

4 years ago
Yes
Assignee

Updated

4 years ago
Attachment #8560365 - Flags: review?(kgrandon)
Attachment #8560365 - Flags: review?(bfrancis)
Reporter

Comment 5

4 years ago
Comment on attachment 8560365 [details] [review]
[PullReq] daleharvey:1117972 to mozilla-b2g:master

r+ from me, with one comment. Nice testing.

Note to UX for UX review: notice that you can't see the OK button on the suggestions notice without scrolling to hide the keyboard.
Attachment #8560365 - Flags: review?(bfrancis) → review+
Assignee

Comment 6

4 years ago
Test fail looks the same as https://bugzilla.mozilla.org/show_bug.cgi?id=1127939

Trying to debug but having trouble due to https://bugzilla.mozilla.org/show_bug.cgi?id=1129937
Assignee

Comment 7

4 years ago
Forgot to remove the test file that I had split out 

Green run @ https://treeherder.mozilla.org/#/jobs?repo=gaia-try&revision=a2bb61697afd

https://github.com/mozilla-b2g/gaia/commit/f496f9e64abecce8cef057e939c289c60ed8b95d
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 8

4 years ago
Comment on attachment 8560365 [details] [review]
[PullReq] daleharvey:1117972 to mozilla-b2g:master

Landed
Attachment #8560365 - Flags: review?(kgrandon)
Could you please uplift to v2.2? Thanks.
Flags: needinfo?(dale)
Assignee

Comment 11

4 years ago
Comment on attachment 8560365 [details] [review]
[PullReq] daleharvey:1117972 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Part of feature 2.2 development
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Flags: needinfo?(dale)
Attachment #8560365 - Flags: approval-gaia-v2.2?
This issue is verified fixed on Flame 3.0

The FTE Phone Tour has been updated to reflect the new way that the search app displays results, which is 4 app results from bookmarks, marketplace, or E.me at the top and then a list of search options below based off of the search provider being used.

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150210010523
Gaia: 0cf517083f7eb5fc269e1236edba50534f65e3cd
Gecko: 2cb22c058add
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

The verifyme keyword has been added for this bug to be verified on Flame 2.2
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Attachment #8560365 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Comment 13

4 years ago
This issue has been verified successfully on latest Flame2.2
STR:
1. Launch Serch bar.
2. Input some keywords.
**You can see the same phenomenon with comment 12
Verify video:" verify_1117972.mp4".

Flame 2.2 build:
Build ID               20150210002516
Gaia Revision          b30c8e4303595a0fcb5b640d673cf8503b954701
Gaia Date              2015-02-10 04:09:47
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3e9fa4e70a1b
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150210.041059
Firmware Date          Tue Feb 10 04:11:10 EST 2015
Bootloader             L1TC000118D0

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme

Comment 15

4 years ago
This issue has been verified as pass on latest Nightly Flame2.2&Nexus5_2.2 by the STR in Comment 13.

Antual result:The search app displays results, which is 4 app results from bookmarks, marketplace, or E.me at the top and then a list of search options below based off of the search provider being used.

Verified Video:verify_2.2.3gp

Flame 2.2 build:(pass)
Build ID               20150705002505
Gaia Revision          ea11f422b687a982f0a961c9aea7858066561707
Gaia Date              2015-07-02 23:37:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0214b4c1ea0
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150705.040440
Firmware Date          Sun Jul  5 04:04:51 EDT 2015
Bootloader             L1TC000118D0

Nexus5_2.2 build:(pass)
Build ID               20150705160206
Gaia Revision          dc6c18c0dea7af3c40bfff86c530fd877d899dc4
Gaia Date              2015-07-04 01:35:20
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/136c41fca853
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150705.193225
Firmware Date          Sun Jul  5 19:32:44 EDT 2015
Bootloader             HHZ12f
You need to log in before you can comment on or make changes to this bug.