Create test to catch regression in bug 1117981 - Lockscreen doesn't show updated time after being woken up from sleep

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: pbylenga, Assigned: njpark)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

5 years ago
In Bug 1117981, allowing screen to timeout and then unlocking showed an unexpected earlier time on lockscreen.
I think No-Jun actually already has something like the beginning of a gaia-ui test in bug 1116672 for this.
Depends on: 1116672
Blocks: 1117981
Assigning this to No-Jun in the light of comment 1.
Assignee: nobody → npark
QA Whiteboard: [fxosqa-auto-backlog+]
Assignee

Comment 3

5 years ago
oh, I have this already in my imagecompare branch. I'll create a new branch for it and submit a pull request.
Duplicate of this bug: 1119404
Summary: Create test to catch regression in bug 1117981 → Create test to catch regression in bug 1117981 - Lockscreen doesn't show updated time after being woken up from sleep
Assignee

Comment 6

5 years ago
Comment on attachment 8548709 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27369

I'm pretty sure I'll get a plenty of feedback for my approach here.  Could you see whether my test case steps are effective?  Also, it seems that it takes about 8 minutes to reach line 32 in B2G desktop, so i only check it up to '12:3'
Attachment #8548709 - Flags: review?(martijn.martijn)
Attachment #8548709 - Flags: review?(jlorenzo)
Comment on attachment 8548709 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27369

The test fails on my b2g desktop as well as on Treeherder[1]. I think we could change the time like a user would do or waiting until the change appears on the lockscreen.

[1] https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=4e45e90041ad
Attachment #8548709 - Flags: review?(jlorenzo) → review-
Assignee

Updated

5 years ago
Blocks: 1122503
Assignee

Comment 8

5 years ago
So I found bug 1122503 while writing tests, and I think we need to wait until this bug is fixed.
Attachment #8548709 - Flags: review?(martijn.martijn)
Assignee

Comment 9

4 years ago
I made some changes here, and it's consistently passing on my machine. but I can't get the try server to pick up my change, (even when I open/close pull request) has something changed?
Attachment #8562500 - Flags: review?(martijn.martijn)
Assignee

Updated

4 years ago
Attachment #8562500 - Flags: review?(jlorenzo)
Comment on attachment 8562500 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27369

A couple of minor issues, the big one to me is when we do an action or not depending on the state of the UI. This can lead to false positive results. More details in the PR.
Attachment #8562500 - Flags: review?(jlorenzo) → review-
Comment on attachment 8562500 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27369

Just some minor issue, but since jlorenzo already r--ed it, I'll wait for your updated pull request.
Attachment #8562500 - Flags: review?(martijn.martijn) → review-
Assignee

Comment 12

4 years ago
Comment on attachment 8562500 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27369

Made changes based on the comments, and squashed commits.  retrying for review.
Attachment #8562500 - Flags: review?(martijn.martijn)
Attachment #8562500 - Flags: review?(jlorenzo)
Attachment #8562500 - Flags: review-
Comment on attachment 8562500 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27369

Some minor nits, and some comments, which you need to act upon or provide feedback why you disagree with, then this is r+ from me.
I tested it locally on my device and it ran at 11 times without failure.
Attachment #8562500 - Flags: review?(martijn.martijn) → review+
Comment on attachment 8562500 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27369

Looks good to me. Runs on my device and test_settings_change_time_format.py is not broken by the change you made.
Attachment #8562500 - Flags: review?(jlorenzo) → review+
Assignee

Comment 15

4 years ago
It is merged in gaia:
https://github.com/mozilla-b2g/gaia/commit/fade7b7ec93cbd866279f20eb3960779cccf385f
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.