Flame: changing timezone bricks the device

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: njpark, Unassigned)

Tracking

({qablocker, regression})

unspecified
All
Gonk (Firefox OS)
qablocker, regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
STR:
Full flash the build
- Go to settings, Date & Time, and change timezone to Atlantic Ocean
-  disable 'Set time Automatically'
- Change time
- Change timezone back to 'America'

Actual:
Screen goes dark, and often it need to be reflashed.  Otherwise, the phone reboots itself after 10 minutes or so
Expected:
Timezone is changed


Version Info:
Gaia-Rev        bcc76f93f5659ac1eb8a769167109fd2d7ca4fbd
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/c1f6345f2803
Build-ID        20150115010229
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150115.043033
FW-Date         Thu Jan 15 04:30:42 EST 2015
Bootloader      L1TC000118D0
(Reporter)

Updated

4 years ago
Severity: normal → critical
(Reporter)

Comment 1

4 years ago
This is also reproducible in 2.2 as well:

Gaia-Rev        2f916cdba7305b51a72482b6bfe860c5b8924f9c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b4c7c83a44a5
Build-ID        20150116002502
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150116.040322
FW-Date         Fri Jan 16 04:03:33 EST 2015
Bootloader      L1TC000118D0
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.2?
(Reporter)

Updated

4 years ago
Depends on: 1118054

Comment 2

4 years ago
Triage: this is not related to settings app, regression window wanted then we'll put to the proper component
Keywords: regressionwindow-wanted
putting qawanted for branch checks to find all that's affected, but also leaving regression window wanted tag.

We should treat this as an urgent.
Keywords: qaurgent, qawanted, regression
QA Contact: bzumwalt
Branch checks below. Leaving keywords while working on regression window.

Issue does NOT occur on Flame 2.1

Changing time zone and time before switching back to the original time zone does not cause phone to freeze. Behavior appears normal.

Device:  Flame 2.1
BuildID: 20150120001202
Gaia: 77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko: f05d0a2d2378
Version: 34.0 (2.1)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Issue DOES occur on Flame 2.2 and Flame 3.0

Changing time zone and time before switching back to the original time zone causes phone to freeze, making it necessary for phone to be reflashed as the device does not move past Thundersoft splash screen if battery is removed then replaced.

Device: Flame 2.2
BuildID: 20150120002507
Gaia: f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko: 5d7497ce4cc7
Version: 37.0a2 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0 Master
BuildID: 20150120010227
Gaia: a5c5ac093814a80b0627514c3bd5f9e96c096a4b
Gecko: c1c6840d9255
Version: 38.0a1 (3.0)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
B2G-Inbound Regression Window:

Last working b2g-inbound build:
Device: Flame 2.2
BuildID: 20141114145046
Gaia: 12e2da14efee4fa564759ef64038b6c6cfe4a04b
Gecko: dc47e33ebd16
Version: 36.0a1 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken b2g-inbound build:
Device:  Flame 2.2
BuildID: 20141114151745
Gaia: 763683f27482075caaed47f9348e84ebf8a175d5
Gecko: 704ca670e7b4
Version: 36.0a1 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


Working Gaia with Broken Gecko issue does NOT occur:
Gaia: 12e2da14efee4fa564759ef64038b6c6cfe4a04b
Gecko: 704ca670e7b4

Working Gecko with Broken Gaia issue DOES occur:
Gaia: 763683f27482075caaed47f9348e84ebf8a175d5
Gecko: dc47e33ebd16


Pushlog:
https://github.com/mozilla-b2g/gaia/compare/12e2da14efee4fa564759ef64038b6c6cfe4a04b...763683f27482075caaed47f9348e84ebf8a175d5

Issue appears to be caused by changes made in Bug 840790
Keywords: qaurgent, qawanted, regressionwindow-wanted
Ryan, can you take a look at this please? This issue could have been possibly caused by the landing for bug 840790
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(ryanvm)
Questions like that should be directed at the patch author, not the person who landed it on their behalf.
Flags: needinfo?(ryanvm) → needinfo?(anusha91rao)
Also NI :fernando  to see if he can help with the backout ASAP as he helped review : https://bugzilla.mozilla.org/show_bug.cgi?id=840790
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(fernando.campo)

Comment 9

4 years ago
Ktucker: can you tell me what is the problem faced by the landing of the patch to bug 840790?
Flags: needinfo?(anusha91rao)

Updated

4 years ago
Component: Gaia::Settings → Gaia::First Time Experience
I just tested the STR with and without the patch for bug 840790 and I am able to repro with the patch applied :(

I don't fully understand why exactly it is failing, as the patch only modifies a json file on shared, or why why it fails on settings and not in ftu for that matter.

The quick fix for the crash would be to revert the commit, but I'm not sure that would be the ideal solution, as we (at least I) don't have any idea of what exactly is the cause of the problem.
But reverting, at least, fixes a potential crash and gives us some time to re-fix bug 840790 without the crash.
Flags: needinfo?(fernando.campo)
Created attachment 8553805 [details]
No errors log

log for the STR once the revert is applied, no crash detected.
Created attachment 8553807 [details]
crash log

log for the STR with the patch for bug 840790 applied. 
End up crashing

Comment 13

4 years ago
fcampo, 
what do you suggest?
Does it have any test cases attached to it?
Or should I resend the patch testing for this bug along with the previous fixed one?
My recommendation would be a backout. 
The original bug 840790 wasn't a blocker, so getting rid of this regression seems to be more important.

I don't know about any test case attached, and the STR (change region + change time + back to original region) seems to me like an edge case, but I'd rather see a patch for 840790 that doesn't break settings.
(Reporter)

Comment 15

4 years ago
FYI, this was discovered when writing an automated test case for bug 1118054
Duplicate of this bug: 1129308
fcampo, I think it's because it's cross referenced with the time zone in gecko.
ex:  http://mxr.mozilla.org/mozilla-central/search?string=Kerguelen

I think you'll need to do an update on the gecko files as well.

That's just my guess.
The commit that causes this bug needs to be backed out asap.
Keywords: qablocker
I am working with mhenretty(Thanks!) to get this backed out, I am really surprised this has not happened till now.

:facmpo/anusha,

PLease note these kinds of regressions have to backedout immediately so we do not affect a lot of folks!
Fixed by backing out bug 840790.

master: https://github.com/mozilla-b2g/gaia/commit/e058a2ae496b9885fb26663c3b40fd62e579a39e
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Keywords: verifyme
Still reproducible, will try a later build.

Build ID               20150204160237
Gaia Revision          b9607aef7debbde09a8db801ce4d021b8262e7f3
Gaia Date              2015-02-04 16:29:57
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3cda3997f45d
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150204.192122
Firmware Date          Wed Feb  4 19:21:34 EST 2015
Bootloader             L1TC000118D0
(In reply to Eric Chang [:ericcc] [:echang] from comment #22)
> Still reproducible, will try a later build.
> 
> Gaia Revision          b9607aef7debbde09a8db801ce4d021b8262e7f3

Yup, this was just a few commits before my backout. Let me know if today's build is still failing.
This issue is verified fixed on Flame 3.0 and Flame 2.2.

Results:  The phone does not freeze up when changing the time zone.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150205010209
Gaia: 2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko: 34a66aaaca81
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150205002503
Gaia: c2047a46e29696238e9b4c9caaba47736421449a
Gecko: adfba0a07e9b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: affected → verified
status-b2g-master: affected → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.