Closed Bug 1118097 Opened 6 years ago Closed 3 years ago
Element : According to Open Mobile spec, the reader names should support slot based naming convention
The parent process (SecureElement.js) should return readerNames based on slots.i;e; instead of current way of returning 'uicc', return 'uicc<slot#>' etc...
So returning 'uicc' for the first slot is actually ok. From Open Mobile API specification V2.05, Reader.getName(): >The slot number “1” for a reader is optional (SIM and SIM1 are both valid for the first SIM-reader, but if there are two readers then the second reader must be named SIM2) In our API (SEReader) we currently have |type| property instead of |name|. I think we should change type to name in this bug and leave the slot numbering for multi-sim support implementation (Bug 1118099).
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.